IBOOK G4 won't boot

[Closed]
Report
-
 UGH! -
Hello,

Forgive the ignorance but I am new to Macs...

I inherited an IBook G4...worked fine for a couple of months, now it won't boot up. It chimes and goes to the apple, then I get the "waiting" icon, and it will do nothing. I have tried resetting as described in this forum, and finally got to the DOS screen, it does fine, then "could not establish default connection to window server" error message comes up and it keeps scrolling with the same message.

It has a new (charged) battery and a new power cord. I also tried the setup cd, which is now inside the machine and won't eject. I think I am screwed but does anyone have anything I might try? Also, if nothing else, how can I get the cd out? Hopefully without dismantling the whole thing, can't find a manual ejection button.

Thanks in advance
Related:

2 replies

i have the disc for ibook g4 but the disc that i received is called mac os x install disc 1&2 ut when i install it nothing happens?

any advice!!
7
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

AND...I can't get it to go to safe boot. Grrrr.
Try putting pressure on left palm rest while starting machine with power button. Keep pressure applied, eject disc.
thanks lojoman.... that tip worked