My xbox360 cannot read my Skyrim's disk with one account, but can with others

Closed
Idontknowwhy - Aug 9, 2021 at 05:19 PM
 sammymelo74 - Oct 14, 2021 at 08:43 AM
Hello. Recently, I had a problem with my xbox. When I tried to enter Skyrim (with my account), it couldn't read the disc. It still didn't work after cleaned it. When using another account, it suprisingly worked. After that, I again tried to enter using my own account, but for some reason, it still wasn't working. It said something like "the disc is unreadable". Can anybody help?

2 replies

David Webb Posts 3177 Registration date Monday November 25, 2019 Status Administrator Last seen October 7, 2021 6,940
Aug 10, 2021 at 06:47 AM
Hello, it is odd that you were able to read it with one account, and not another, as typically discs not being read are the result of a physically damaged disc, and not software related.

With the account that manages to read the disc - have you actually tried to play Skyrim? You may find that beyond recognising the disc, you can't go any further.

Regards
1
My Skyrim Disc isn’t working on my Xbox 360 ,

I have cleaned it really well ,

But still not really not working ,

Can anyone tell me how to get it Skyrim Disc working again please ? ,

I have restarted my Console as well ,

I need to know ASP Please
0