RX 6000 Series MacOS Compatibility

Solved/Closed
PhumeleleToniJose
Posts
2
Registration date
Sunday January 9, 2022
Status
Member
Last seen
February 1, 2022
- Jan 20, 2022 at 06:26 AM
HelpiOS
Posts
12346
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
May 21, 2022
- Jan 20, 2022 at 09:16 AM
Just for reference Navi 21 and 23 are the only RX 6000 version compatible with the MacOS at this time.

Navi version support is an Apple issue and relates to the drivers Apple has incorporated into MacOS. The drivers are likely to only be incorporated for the RX 6000 versions that Apple sells for the Mac Pro.

The 6800, 6800 XT and 6900 XT are all Navi 21 which are compatible with the current releases of MacOS Big Sur 11.4 and after and Monterey. Apple added support for the 6600 and 6600 XT (Navi 23) starting with MacOS 12.1.

It has been confirmed that the 6700 XT (Navi 22) is currently not compatible. It can be assumed that the 6400, 6500 and 6500 XT (Navi 24) will also not be compatible unless Apple adds the drivers.

Hopefully this stops people from going down the rabbit hole of compatibility with all announcements of the cheaper RX 6400 and 6500 series cards.

1 reply

HelpiOS
Posts
12346
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
May 21, 2022
1,801
Jan 20, 2022 at 09:16 AM
Hi,

Thanks for sharing this with us!

Best regards
0