Unknown device on acer 2920 6A4, please help

Closed
DigiTuur Posts 2 Registration date Sunday August 10, 2008 Status Member Last seen August 11, 2008 - Aug 11, 2008 at 03:59 AM
 DigiTuur - Aug 13, 2008 at 11:58 AM
Hello,

I installed vista 64 bits on my Acer Aspire 2920 6A4, using the drivers from the Acer site

Everything went well, except one thing.

I can see 1 unknown device in my device manager.

Everest Ultimate Edition identified this unknown device as:

Hardware Identification HDAUDIO\FUNC_02&VEN_11C1&DEV_1040&SUBSYS_10250100&REV_1002
Location information Internal High Definition Audio Bus

Does anybody know where I can find the right driver for this device?

I have been searching the internet for some time now, with no luck.

Please help

2 replies

aquarelle Posts 7119 Registration date Saturday April 7, 2007 Status Moderator Last seen October 18, 2022 491
Aug 11, 2008 at 04:13 AM
Hello,
Try Acer support website and choose your Vista then download Audio_Realtek driver : https://www.acer.com/worldwide/support/
Best regards
0
DigiTuur Posts 2 Registration date Sunday August 10, 2008 Status Member Last seen August 11, 2008
Aug 11, 2008 at 04:29 AM
Thank you aquarelle,

I tried both the vista 64 realtek driver and the vista-sp1 64 realtek driver as provided by Acer, but to no avail.

The unknown device is still there.
0
aquarelle Posts 7119 Registration date Saturday April 7, 2007 Status Moderator Last seen October 18, 2022 491 > DigiTuur Posts 2 Registration date Sunday August 10, 2008 Status Member Last seen August 11, 2008
Aug 11, 2008 at 04:32 AM
Do you reboot your computer after installation ? Often, it is necessary.

And are you sure you have got a 64 bits ? Maybe it is just the 32 bits so you have to choose it in the first list of Vista.
0
I partly solved the unknown device problem.

In Device Manager I deleted the device and restarted my computer.
Than a new device was found and it turned out to be a Modem device on high defenition audio bus.
I used PCWizard and that identified the modem as a Foxconn.
So I installed the Acer 64bits Foxconn driver, but that one didn't work.

I still have to look into the driver subject, but I don't use a modem and I don't think I wil ever use one, having broadband internet and all that.

Thanks for the help anyway
0