OSX Leopard

Closed
Mel - Sep 8, 2008 at 12:38 AM
 tetor - Jan 22, 2009 at 06:30 PM
Hello,
I will preface this by saying "this might be a dumb question" but.... Can I run OSX Leopard on a my mac that is OSX version 10.3.9? I need some advice about the possibilities of making my computer more current but I realize that I don't have the newer processor. Maybe I'm out of luck but I certainly can't afford a new computer.
Thanks for any advice!
Related:

3 replies

lostseasons Posts 10 Registration date Sunday August 17, 2008 Status Member Last seen April 1, 2009 5
Sep 8, 2008 at 04:28 AM
hey there,

can you tell me the actual configuration of your mac because i have been searching on apple web site itself and have found that with a normal pc with configurations core2duo and 2gigs of ram the mac oxs leopard would suite.

see you
2
well i have the mac os x 10.3.9 and i just wanna upgrade
0
could you do it on a amd athlon 64
0