Pen drive unable 2 write after win 7 upgrade

Closed
Report
-
 Sudhir bidye -
Hello,
I have a Kingston 4 GB usb pen drive,

I am able to store large files (>50MB) on computers running on xp.

However, pen drive unable to store large files (>50MB) on computer running windows 7.

No problem reading from usb, but when i write data on it , stops midway and usb drive disappears.

Have formatted drive with both fat32 and NTFS, scanned fo errors, scanned for viruses but no improvement.

Plz Help!!!!!!!!!!!

1 reply


Dear Carl,

This could actually be caused by the fact that the key that

you are using contains some partitions. The problem will

easily be solved by deleting these partitions. I will reccomend

you to get through the instructions in the below Kioskea FAQ

article in order to have the problem solved.

https://ccm.net/faq/1782-files-are-missing-from-the-flash-drive

Hope that the information provided solves the issue.

Thank you.
Many thanx for your kind reply.

We have now formated the pen drive to FAT32 and now only primary partition exists.

Unfortunately, pen drive still disappears from system after copying only 70 - 80 % of the file when we try to copy any file of greater than 100 MB.

Your assistance will be greatly appreciated.

Regards