Linksys WRT54G and Charter [Solved/Closed]

Registration date
Tuesday January 22, 2019
Last seen
April 18, 2019

I've used my Linksys WRT54G wireless router with Charter cable internet for a few years. Small problems here and there but nothing a reboot/power cycle cannot solve. However since yesterday, all of a sudden I can no longer get online with the router. I can get online just fine if I connect the cable modem directly to my computer, but not through a router. The "internet" light on the router just kept blinking semi-rapidly. I've tried resetting the modem and the router numerous times but to no avail. And I didn't change any settings at all since it's been working fine for me for the past few years.

Can anyone help me? Or is it time to get a new router?

I am running Vista with Charter Cable, Motorola SB5101 cable modem (1 month old). Any help is appreciated, thanks!

27 replies

I just called Charter with this issue. They maintain this issue is with Linksys. Here's what they say: With dynamic IP renewal every 24 hours Charter provides new IP addresses that are out of the acceptable range that Liksys likes. This results in the super-fast internet light blink. The tech said the remedy is to use the Charter power down cycle (not the Linksys one). Here's the steps:

1. Power down the modem and linksys router(s).
2. Disconnect the coax cable from the modem and wait 35 seconds.
3. Connect the coax and power up the modem.
4. Once the modem has a solid ready light power up the router(s).
5. Try to acces the internet after 25 seconds.
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

Used comcast with WRT54G...tried this an it worked. Charter and Comcast must be hiring from the same talent pool.
lol......I just spent literally 5 hrs screwing with this router........... and this worked.. Im not sure with whom im angry with. myself, Linksys or Charter....
THANKS!! worked great
OMG hours and hours of trying to figure this out and I so did not think this was going to work at all and wa-la! works!
Registration date
Tuesday January 22, 2019
Last seen
April 18, 2019

My Linksys wireless router sudden stop working and I was unable to access the router’s web-based setup page. I found it solution my Linksys's official website. here is the link with other problems and solutions.
here are the comprehensive steps that I took to make my situation work using a combination of the above. I tried other variations (power cycling and MAC address cloning individually did not work for me).

reset Linksys using a pen to click the little button on back
unplug Linksys power
unplug modem power
unplug modem coax
wait 30 seconds
plug modem power and coax back in
wait until modem power light is steady
plug in Linksys power
wait for Linksys power light to steady
go to admin page:
make sure DHCP is enabled, enter hostname
go to MAC Address clone tab, generate and save

unplug Linksys power
unplug modem power
unplug modem coax
turn off computers
wait 1 min

plug in modem coax and power
wait for modem power light to steady
plug in Linksys power
wait for Linksys power light to steady
turn on computers
go to Linksys admin page, configure security (e.g., WEP or WPA)

access through PC(s)
check that PCs are now connected wirelessly

go to admin page and configure anything else (port fowarding, etc.)
I figured it out, here you go all....

Most cable ISPs use a MAC Authentication to establish Internet connections for end-users. A MAC (Media Access Control) address is assigned a unique 48-bit (6-byte) integer that is attached to an Ethernet NIC for each computer. To set-up your Linksys router to a Cable ISP, you have to do MAC Cloning. MAC Cloning is a procedure which enables a router to copy the MAC address of the PC that's registered with the ISP.
That did the trick fro me. Thanks for posting!
Okay, I guess (know) I'm a tech dummy, but since I can't access the internet when the router is connected, I can't do this MAC cloning procedure. Or am I not understanding something? Thanks.
you won't be able to access the "internet" but you will be able to access the LAN which is the set of computer connected to your router and the router itself. so you will be able to do the above
Charter blocking Linksys & Belkin routers (Fixed)
This has been a week long and costly ($99) event where nothing would work properly with my Linksys wireless N router.

What has happened Charter found a way to block or seriously disrupt a routers operation (new Belkin router was going on and off like a blinker) for the assumed reason of selling their leased routers at $5 per month,After multiple calls that was the only solution they offered.

The Fix:This was done with a Windows7 laptop computer and new Belkin router.

1. Connect laptop computer to cable modem directly with Ethernet cable,make sure you can surf the Internet properly,go into the connection properties for the LAN connection and look for IPV4 gateway,DHCP server,DNS server numbers,write down the DNS server number and the one below it.

2. Connect laptop to router and log into setup screen(http://router or Belkin router)

3. Under Internet WAN settings set connection type to dynamic and leave host name blank,set DNS numbers to the ones you wrote down in step #1,Under MAC address setting clone your laptops mac address into the router.

This makes the router appear to be a computer from Charters end.

4. Power down reset everything, Fixed !!
There is a known problem with many devices. It has to do with the renewal of the DHCP license (typically, every day). Many of the industrial routers handle the renewal via the line cards rather than the router's main processor. However, that code is new and was designed according to some updated standards ... in particular, the size of the packet (old DHCP used a fixed, minimum, packet size). A lot of "leaf" (end of line) devices reject DHCP messages sent over short (newer) packets do not conform. So, when the new line card software sends the "new" format DHCP renewal, the device (the router) ignores it.

The work-around, so far, is to power cycle the leaf MoDem/router combo. That forces the (more capable) software in the back office router into play and the renewal becomes a new connection.

Pain in the butt? Yes! It looks like some kind of fix will have to be applied to the Cisco and Juniper hardware (I think Juniper already has the fix deployed) to compensate because the various ISPs aren't going to spring for upgraded leaf equipment for everybody.

Is this the cause of this, reported problem? I don't know, but it sure sounds similar to the problem that Verizon had a short while ago.
Yeah there's something fishy going on. Same thing happened to me only with Netgear router. They had me unplug the coax and power twice. They told me my router was resetting the modem's IP. I've never heard of such a thing. Then they tried upselling me their router/ modem combo. I got pissed and hung up. Then I resetted the modem myself, followed by my Netgear router. Bam, works just fine now. I think they are finding a way to block the signal and upsell their router. God I wish I could talk to one of these A holes in person, their full of crap.
They are doing that and trying to upsell. Happened to me, my parents and my sister all in one week. Three different household all have the same problem with Charter? Gimme a break.
I forgot to mention, two of us use linksys, one uses a d-link router. So again, it is not the router or modem. It IS the company. Or at least that would be what it seems like. All 3 of us live in the same town as well. Ugh. I wish there were another service provider we could choose from.
i'm an espiring computer tech. and to my knowledge it is a simply tweak of the settings on the router site. instructions are below:
1.access the router site-
2.under setup go to mac address clone and clonoe your pc's mac.
3.under administration go to manaement
4.under web access click disable
5.under (UPnP) click disable. your changes
None of those settings are related to each other. You are full of it.
Universal plug and play shouldn't have any impact on the connection to your ISP. If Charter is in fact disallowing the use of a Linksys router by limiting which MAC addresses they'll accept, that's total bullpucky. All you should have to do is clone your PC/Mac's MAC address to the router. None of the web access changes or UPnP changes should be necessary.

All you need to do is spoof/clone your mac from a desktop to your router, I beleave it can do this. Enjoy.
I had the same issue with Charter some time back my older WRT54G stopped collecting and address from the Cable modem. I could not get it to hook back up so I bought a Belkin and everything was good except for the nearly daily disconnect which would sometimes require a power cycle on the modem and/or router. Yesterday it just would not come back and I could not connect even straight from my laptop to the cable modem. Calls to Charter had me doing all the normal stuff they make you do which got me back to where the computer would connect directly but the router would not get an address. All while the girl on the phone asserted a bunch of stuff about networking that I know not to be true.

I asked her if she had re-provisioned my cable modem though and she did say yes.

Anyway, I got out the old WRT54G which is running DD-WRT and it would not connect either. Finally today I disconnected the coax and power from the cable modem for about three minutes, connected it back and what do you know the old router connected right up.
If you are doing peer-to-peer downloads/uploads, as with torrents, your router can easily be overwhelmed by 60 or more peers. You need to clone (or reclone) you ethernet hardware address from your PC to your router. Just connect your PC to any of the LAN ports (not the WAN port typically) on your router and follow your router's documentation. Then shut down everything, restore you usual configuration, and boot it all back up starting with the modem, then the router, then your PC...

This is a CHARTER problem. I have the SAME linksys with Charter and suddenly, last night, for no reason... Poof! I get piss poor performance through the Linksys but full-speed directly connected. Charter made a change and they're not fessing up to it.

They told me my modem was "antiquated" and the guy hung up on me when I started blowing holes in his script.

Charter sucks but, I'm stuck with them where I live
obviously, you dont understand how cable internet works.. it is possible your router is incompatible or for some reason is not working properly anymore.. the test is to hook up direct to modem, If you have service, then your ISP is providing you with what you are paying for. If you choose to go wireless after that, it is your equipment and you will need to get with your router manf. to resolve the issue or buy a new one. they do go bad. Also, I have see a brand new router out of the box bad from the start.. good luck!
I had the same problem after switching from dsl to cable. I thought the change had something to do with it, but the router worked fine initially (about 5 minutes) then stopped, internet light blinking or fluttering. After many phone calls and attempts to re-configure/reset the router, I broke down and got a new one WRT110 figuring the old one was fried somehow. The new one works fine, but I haven't done anything more with the old one and am still wondering if it's really bad.
Registration date
Saturday November 29, 2008
Last seen
December 8, 2008
1) Check the settings of the router as the provider might have changed something on his side
2) Reset the router to factory defaults and re-setup it
having same problem, reset router to factory settings and re-setup. No avail. The charter modem doesn't seem to allow anything hooked to a router. Even hard wired a router and sent an ethernet cable to another computer, and it will not allow access.
It was great reading through this -- I've been so angry and it is good to know I'm not alone. I am a verizon DSL (fuijitsu modem) user who experienced exactly the same problems. Worked find for years, then suddenly yesterday, no comms between router and modem and no internet access. I could go straight from computer (WinXP) to router and no problem but put the Linksys in the loop and nothing. Hours later with multiple contacts to verizon and linksys talking with reps from halfway around the world -- but I did talk to a southern accented Ralph on one connection--it was a joy to talk to a "Ralph" but anyway -- did all the resets, releases, cloning, new router, and nothing. Got frustrated, left everything alone and went to bed. As of this morning, 12 hours later, it's working again. My guess is the ip address was locked up but frankly I don't know. I have to go back and redo all of my security settings and will advise on anything I find.
I am suddenly having a problem with WRT54GC & Comcast, I have a backup router and had the same problem, following: The router would stop functioning at all, no DHCP, but only when the modem was hooked up. I figured out it was the 'MAC Address Clone', I disabled it but now the router works but the modem won't get an IP address. Like I said, this happens on two physical routers with the same config, so something has happened that makes the router stop working when cloning the MAC address.

This is still not working, and I don't know how to tell Comcast to reset the MAC address, the idiots on the phone don't know what a MAC address is. Any ideas? TIA
I am having the exact same problem even tried two different linksys routers, what gives?
Registration date
Wednesday August 6, 2008
Last seen
February 28, 2009
ok dude just try this with the router start up and connected to your computer,

just open command prompt in wondows and then type in the following command :

after that if the ip is not automatically renewed just type:

Hi thanks for the reply. I have tried to release and renew but it's still acting the same. Worst yet, I wasn't able to use internet for an entire day no matter what I did. The technicap support asked me to do the same thing (release renew etc) and to no avail. She said for some reason the modem isn't giving me the correct IP address, and she asked me to shut down the modem for an entire night and see if it fixes itself.

The next day, I am able to connect to the internet, but again, I can't do it through a router, only a direct connection.

I'm suspecting the problem is with the modem, does anyone have similar experience?
Did you ever find a fix with your Linksys. The same thing happened to me and Charter try to sell me there wireless system but would noy admit to a change. Any luck?

I have been having this problem for a while. And I got the same 'Blow-em off' answers from charter. I hope this works. Thanks Folks.

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!