Icons in my start menu/desktop dont work!HELP

Closed
xoxoloved
Posts
1
Registration date
Saturday February 20, 2010
Status
Member
Last seen
February 20, 2010
- Feb 20, 2010 at 09:41 PM
 Priz - Feb 15, 2012 at 06:44 AM
Hello,

I had recently accidently accuired a virus on my laptop. I had all of the malicious software and problem starting files removed from my computer by Norton Internet Security by Symatec. Now when i click an icon on my start menu or desktop it says either: This file does not have a program associated with it for performing this action. Create an association in the Set Associations control panel. (This does not work because the shortcut name dose not come up in the Set Associations Control Panel) or it says Choose the program you want to use to open this file accompanied by a list of programs and the ability to browse. (If i choose one it will work temporarily but not the next time i click it.) What can i do to fix this? Any Tips? I have Windows Vista Home Edition. Please help!!

4 replies

gazmakka
Posts
6
Registration date
Thursday March 25, 2010
Status
Member
Last seen
March 25, 2010
2
Mar 25, 2010 at 08:31 AM
Hi.
Read the second paragraph before the first

Have you tried creating new shortcuts from your Start > All Programs list to desktop and click one see if it works?
Your existing desktop shortcuts may no longer point to anything.
You could also get the free C Cleaner from Piriform and run Cleaner and the Registry options. Its great for clearing out missing links in the registry.
The free 30 day trial of Trojan Remover will get in there and find a nastie that Symantic missed....as can happen. If you get TR, Update its Virus Bata base before using it.
A CHKDSK C:/F set up in command prompt and a reboot to kick it into action wouldn't go astray either.
Tried a System Restore...................beware the festering virus thats in there just waiting to be reborn.

READ THIS FIRST



I had the same problem that you have and the fix was to find the reason why. It turned out to be the Virus had altered the file extensions and everthing that I tried to open opened in Notepad.
I posted a thread to Press F1 and I was told that it is a File association muck up and that I should look into the file suffixes attached to my files/programs.
I didn't need to as I figured that the .exe had been changed to Notepad, and what showed on screen was completely illegible to me...hieroglyphs. I downloaded an.exe fix from the webpage and my troubles were immediately fixed.
Here is a link to a webpage that deals with fixes for Vista file associations.

https://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/

If you try it, when it says to "Right click and save the file" it means "Right Click > Save link as...". A window will open and just click Save. It will be saved to Documents or as I use Firefox, they are saved to downloads.
Hope it helps.
gazmakka

ps: ignore the offers to download reg fixers and all that. What I think you may need is at the top 3inches of webpage.
The comments and threads by people are very interesting and helpful. Sounds to me that they had exactly what you have at present.
ciao
1
I have the exact same damned problem. It angers me no one has answered this yet. I keep having to run everything as an administrator and it's really pissing me off!
0
my computer is also suffering from the same problem....started just after i got rid of a vista security 2010 virus and theres too many programs that need associating to do individually! need a fix ASAP!!
0
I have successfully download the exefixer. My programs are working again, but the icons are still the same, the notepad icons. Do I have to change all the icons of my programs manually? Thanks.
0