Powerbook g4 no boot after shut down [Solved/Closed]

tony - Oct 8, 2008 at 06:38 PM - Latest reply:  Jurgyguy
- Mar 29, 2013 at 10:06 AM
Hello,


I have a powerbook g4 notebook, I shut it down and left it plugged in for a couple of days, then I tried to powe it up but it does nothing at all. the powe supply light comes on green-normal light but the computer wont even start at all. Itried removing the battery and power supply for hours and even a whole day but it wont do nothing at all not even a light comes on. What do you think the proble is or what do I need to do?

Thanks

Tony
See more 

11 replies

Best answer
5
Thank you
Tony

IF I remember correctly, there is a reset button inside the battery compartment. Take off all power (as you have done) and hold down the button for 15 seconds or so.

You should be good to go.

Thank you, Cookie 5

Something to say? Add comment

CCM has helped 1700 users this month

2
Thank you
thank you thank you!! it worked for me too!! opt+ctrl+shift+power button. thanks a mill!
hey obviously i'm innocent here,can somebody help me show where the option button please?i have the same problem with my powerbook g4.
lauras_auras > tom - May 14, 2009 at 02:25 PM
The option button is located last/bottom row . The 1st key shows fn 2nd one shows ctrl the 3rd one shows both the words : options and in smaller letters alt
hope that helped
tom > lauras_auras - May 18, 2009 at 12:17 AM
big thanks laura
1
Thank you
Hello,

Thanks for your response, I have checked all over the computer for a reset button including under the battery but it seems like this computer does not have one. Please let me know if you have any other advise for this powerbook g4 17''.


Thanks,

Tony
Hi Tony,
I have the same problem as you. My titanium G4 17' decided not to start. No chime, no blank screen, nothing. The battery was charged and I thought it was aloose connection. The next day it turned on. I had no idea why. The day after nothing again. I took it to apple and they said they cleaned it!! The computer worked but now I find that it will not start again. If you know whats happening please contact me.
Thank you
Lamyo
travellog > lamyo - Mar 16, 2009 at 09:53 AM
Don't know whether you are still having the power problem you described back in January, but I came across your message when searching about a similar problem. I have since discovered what the problem is. For some reason, the power supply has to be reset. To do this, hold down Option-Ctrl-Shift-Power button for five seconds. Then hit the power button.
gusby > travellog - Apr 13, 2009 at 07:43 PM
Hey just wanted to thank you for this solution. I was having the same problem as described here and your post made me a hero:) Thank you!!
Julie > travellog - May 24, 2009 at 12:34 PM
Thank you!!! You are a hero to me! Luckily I have a work laptop where I could research why my G4 just was black/blank screen (and NOT the contrast button). Thanks for the tip!! I was worried! Best, JB
All this time my home g4 shuts down for days and all of a sudden on it comes, works for long time & shuts down again.the option,Contr,shift,power method is OWESOME!!
Solved all my problems.
Thank god for people like you who help others. You're the real heros who hate to see people get ripped off
Thanks again,