Pendrive folder appears empty [Solved/Closed]

-
Hello,

My system is not reading the folders in pendrive and other folder. Moreover, search option is also disabled.

Please help!

System Configuration: Windows 7 / Internet Explorer 8.0
See more 

10 replies

Best answer
approved by Ratnendra Ashok on Dec 19, 2018
Posts
6499
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
2579
144
Thank you
Hello,
  • Check whether files are not in hidden mode.
  • Click on Start > In search box, type cmd and press Enter.
  • "Command Prompt" will be opened.
  • Here I assume your pen drive letter as G:
  • Enter this command:
    attrib -h -r -s /s /d g:\*.*
  • You can copy the above command --> Right-click in the Command Prompt and paste it.


Note: Don't forget to replace the letter G with your pen drive letter.
  • Now press Enter.
  • Now check for your files in your pen drive.


Good Luck.

Say "Thank you" 144

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 4246 users have said thank you to us this month

I tried as you said and lo and behold!!My files returned
Thanks, it was a great help
-
thank you, you just saved my 4 years of studying.
Thank you very much :D
-
Thank You.. Its work for me...
Posts
6499
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
2579
7
Thank you
Hello,
Try this 1
attrib -r -s -h /s /d g:\*.*
Copy the above command, right-click in the command prompt and paste it
Note : Don't forget to replace the letter g with your pen drive letter.
Or
Click on Start --> Search box, type control folders and press enter. Folder Options will be opened.
Click on "View" tab --> Select the option "Show hidden files, folders and drives" and uncheck the check box
"Hide protected operating system files" and click on OK. Now look for your files in your pen drive.
Good Luck.
Thank you po. It really works. :)
thanks a Lot
Posts
6499
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
2579
1
Thank you
Hello,
Let us know what happens when you are trying to open the folder. Is there any error message that is being displayed ?
Good Luck
1
Thank you
sorry yar it doesnt works
Posts
6499
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
2579
1
Thank you
Hello,
Try this 1
First make sure to check the folder options once again. If you PC is infected then even when changing the option to show hidden files and system files, it won't let you change it.
OR
Download file commander application from the below link and install it
http://www.freecommander.com/
Plug your pen drive ---> open file commander--->select your pen drive. It will help you to access hidden files.
Good Luck
1
Thank you
Bravo! It worked, I can seen my whole files, by this command. some friends facing problem to implement it, I want to suggest all of you as I experienced, that my computer takes some time to drive this command. I just pasted it. changed desired drive name (as already mentioned in main topic), pressed "Enter", Wrote "Exit" And Minimized Command Window to let it its time. And forget, after some time it will be run itself. Thank You.
attrib -r -s -h /s /d g:\*.*

This Code works, just write it in the Run program. And place your location if its H:\ or I:\ or G:\ or E:\
0
Thank you
Thank U Jack.. Even I could recover my data with it..
0
Thank you
It worked yar, thank you very much
-1
Thank you
when I am trying to open my pendrive it shows empty but while checking the properties its showing some used space
-1
Thank you
yes it works
thanks alot
Serveral times I formatted the usb and again copy files into usb but when after removing usb recheck the folder is shwoing empty but space is full as per file

I think it may be usb problem
several t ime I tried the command ATTRIB -H -R -S /S /D G:\*.*
BUT NO BENEFIT