Laptop wont power on

[Closed]
Report
-
Posts
1
Registration date
Thursday February 10, 2011
Status
Member
Last seen
February 10, 2011
-
Hello,
We have an ACER laptop. It is less than 1 year old. All of a sudden, when trying to start Windows, we would get only a white screen. My husband tried a couple times to take out battery and unplug and then replace them both and power on. I got the option to run a system restore. I tried this and after about 20 minutes it said it was unable to fix our problem. So We again removed the battery and unplugged it. Then we replaced both power sources. Now, it will not turn on at all. Please help!


2 replies

Posts
40
Registration date
Sunday November 14, 2010
Status
Member
Last seen
July 12, 2011
4
im happy to help listen to me may laptop too.. is acer and i have a problem too like your problem the damage is video card i cannot open my laptop and i go to technician and said try to buy a new video card bacause your video card is damage or interrupted i hope i help you tnx try my suggestion maybe posibility memory RAM or video card problem cause of wont open your computer
Posts
1
Registration date
Thursday February 10, 2011
Status
Member
Last seen
February 10, 2011

This appears to be a problem caused by the update thAT WAS issued for the BIOS (NOT the CMOS!) on the Acer Travelmates.
I downloaded the new bios from acer, as suggested by them. Followed the instructions for updateing the BIOS to the letter. The screen displayed the whole process of removing the old bios files and also the installing and saving of the 17 new files that were supplied with the update.
After the process was completed a memo came up stating that the laptop had to be re-booted for the changes to take effect. Did the normal of telling it to restart now and that was the last time anything appeared on my screen! Depending on how your PC is configured this process can actually be done without your knowledge ! ( IF you have things set to install ALL updates/upgrades automatically!)
After lots of enquiries I am led to believe that I need to either replace the motherboard or try and reset the bios by moving a switch on the motherboard. No one has been able top point me to the correct switch yet!
THIS PROBLEM RELATES TO SEVERAL MAKES OF LAPTOP ALL USING THE SAME BIOS!
If you find a "fix" please put it on this site!
As the bios has to run BEFORE anything else, we are in a catch 22 situation! Cannot install a new Application or restore the old settings until the bios actually BOOTS!....Damn!