Windows Installer service cannot be accessed [Solved/Closed]

Frustrated - May 3, 2012 at 11:21 PM - Latest reply:  Ziva
- Mar 27, 2015 at 06:20 PM
Hi, all!
I'm running Vista Home Premium on my PC. I tried to install a program and I got the following message: "Windows Installer Service could not be accessed".
I found an article on Microsoft support: http://support.microsoft.com/kb/315346.
Went through method 1. This did not solve the problem. However, when I tried to install the program, I only got the same error message. Next I tried method 2, but when I completed point 3, cmd only said "file not found - dllcache".
Following advice given on an other forum I went to Add/remove programs to see if windows installer was actually there. And, guess what... It was not. So I downloaded Windows Installer, but when I tried to install it, I got the following error: "Not enough storage is available to process this command." I have about 200 GB of free space on my hard disk and 4 GB of RAM, so that seemed pretty strange to me.
Lastly, I downloaded windows installer cleanup, but when trying to install it, I got the same old error message "Windows installer could not be accessed."
I would really appreciate any help as this problem is driving me crazy.
I have also tried the net start MSIServer, regsvr32 c:\windows\system32\msi, MSIEXEC /UNREGISTER and MSIEXEC /REGSERVER in the cmd. I tried going to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer and changing the WOW64 value to 0 but could not find WOW64

The only thing I have found out is that I do not have windows installer becuase when I tried going to Services and make Windows Installer Service automatic I could not file windows installer.

Thanks in advance.


See more 

18 replies

Best answer
Anonymous User - May 6, 2012 at 09:59 PM
8
Thank you
Open it as notepad

Click on FILE-SAVE AS

save the notepad as

Filename:msiserver.reg
Save as type:All files


Now launch the file

Thank you, Anonymous User 8

Something to say? Add comment

CCM has helped 1596 users this month

Anonymous User - May 4, 2012 at 11:37 PM
5
Thank you
I have also tried the net start MSIServer,

Did you receive any error?

If you can find MSISERVER reg key then you should have windows installer service too?

Ok,try this

http://speedy.sh/k6fsD/msiserver.reg

Download and launch the registry key,restart the PC and try to start windows installer

If that doesnt work,create a new user account and see if works.
None except for not enough storage space. I downloaded the file and all it does is open in notepad. What am I doing wrong?
Hi guys, I had the same issue ; struggled on it for days and finally tried the MSIserver as indicated here. I was scared to play with the register but found Sundar's steps easy to follow. It fixed the pb within a few minutes. Thanks a bunch
i have been trying unsuccessfully to fix this problem all night, with various regedit's and so forth - your answer was a last resort and the first one to ever work so thank you very much.
Anonymous User - May 7, 2012 at 10:46 AM
2
Thank you
Right click on the file

CLick on OPEN WITH

Browse to C:\WINDOWS folder

Select REGEDIT file and click ok

Now follow the instructions given before
Anonymous User - May 7, 2012 at 11:02 PM
2
Thank you
Go to C drive,double click on WINDOWS folder

Now select REGEDIT file
Anonymous User - May 8, 2012 at 02:29 AM
1
Thank you
Download

http://speedy.sh/sehBC/subinacl.exe

Copy this file to C drive

Click on startmenu and type

command

right click on command prompt-select-run as administrator,run this command

cd\ Press ENTER

Now copy all these commands together and paste it on the command window

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f



The command should start running,it may take a minimum of 20-30 minutes to finish it.

Restart the PC and see if you still get access denied errors
Anonymous User - May 5, 2012 at 11:38 PM
0
Thank you
Rename the msiserver.reg.txt to msiserver.reg and launch it
0
Thank you
Still opens with notepad.
0
Thank you
Nope still opens in notepad.
0
Thank you
I cannot find Regedti anywhere in my c:\ drive
.
Thank you for you continued help.
0
Thank you
Ran it in regedit and it said it was completed but I tested out an installer and still got the windows installer cannot be accessed error and I restarted my pc
0
Thank you
That did it, thank you so much!
Anonymous User - May 8, 2012 at 04:43 AM
0
Thank you
You're welcome
0
Thank you
you guys are so great thank you guys a million times for this :) :)
0
Thank you
ive found a sulution that worked for me go to this linkand it explains what to do in a couple of minutes http://answers.microsoft.com/en-us/windows/forum/windows_vista-windows_update/i-cannot-download-the-new-updates-from-may-8-2012/b9b4a982-5b4d-4218-8a47-917515ede136

it worked but it tells you iola system mechanic or other registry tuners are at fault after following the instructions I was able to apply updates and install office
0
Thank you
hey guys

i just had the same problem and I tried most of the proposed solutions in the web, particularly those by microsoft. but none worked for me. I came up with the error when installing adobe acrobat 8 professional. the one thing that just worked for me was installing the program in compatibility mode: my OS is W7 (32 bit) and I installed the program in compatibility with XP SP2. i'm not sure if I had tried this at the time I came up with the problem, but now it did it. i'm almost sure that u've done this at the beginning, but if you have not, give it a try.
btw, tnx to all who have contributed to this post.

best of luck