Red X appears beside wifi signal - I'm Stumped!

GENTILR Posts 2 Registration date Tuesday October 30, 2012 Status Member Last seen October 30, 2012 - Oct 30, 2012 at 02:45 PM
 Me - Oct 6, 2017 at 12:06 AM
Hello forum members,

I have a very strange thing going on with my WiFi connectivity and hoping someone can help. I will provide as much info here as I can remember to help get to the bottom of it and avoid unnecessary back and forths. Sorry for all the text!

ABOUT ME: I am an experienced PC user, somewhat tech savvy, and solve most of my own technical problems myself or with the use of online research. But after hours on this problem, I'm stumped!

PROBLEM DESCRIPTION: When I turn on my computer each morning I get a red X beside the WiFi icon and cannot connect to the internet for the first 5-30 minutes. Then, mysteriously it connects on its own. Sometimes I find the 2nd preferred wireless network in the 1st position and the PC is trying to connect to it. It's not supposed to be in the 1st position. Some mornings the icon is normal and is connected to the WiFi but there is no internet connectivity. Yesterday for the first time the icon showed the red X as if it was disconnected but my emails downloaded into Outlook and I could access websites. So the icon was wrong. Originally this problem just started with connection problems upon start up as I just described. But then it got a lot worse with regular disconnection problems during the day. After trying many things I did a system restore which solved it right away. But then the problem has re-occurred and the only thing that changed to my computer is java and windows updates. So I did another system restore and java uninstall to get rid of the java update and the problem occurred again after the windows update. I don't know for sure if the Windows Update is the problem, that is just my suspicion.

After correcting the problem with a system restore.......

On Oct 24 the first sign of trouble started again - I was disconnected from the wireless and got a message saying the PC could not connect to the Echo 3 wireless network. Repair didn't work. Then within seconds it connected to my main Rollins just fine. Just like last time, somehow the Echo 3 network went from #2 to #1 priority where it's supposed to be the other way around.

On Oct 26 I came back to my PC to find the Symantec anti-virus running and no internet connection. Again, it said it could not connect to Echo 3. Somehow this network got bumped up to first place in order of preference - just like last time. So it put it to #2 preference behind Rollins and then got connected. Later in the evening it was disconnected and Echo3 was back at top again. So I removed the last 2 java updates to no avail. So then I did a System Restore back to Sep 27 which seemed to work.

Oct 27: turned on the PC to find it disconnected again and Echo3 back up top AGAIN. Repair didn't help. So removed Echo 3 to force it to use the Rollins network and clicked connect to Rollins. This worked and got me connected.

Oct 27: I was prompted to install a Firefox security update which I did. When I turned off the PC a pile of windows updates loaded on.

Oct 28: low and behold I could not connect to WiFi for the first 15 minutes after starting the PC in the morning. Repair didn't work, clicking connect didn't work, and then it suddenly did connect on its own. Just as on a previous occasion, connecting to websites was very slow and the "connecting" indicator went on for quite a few minutes. I hit send/receive on Outlook email and it took quite a few minutes before getting the message that it failed. Tried to update ZoneAlarm but received "product error" message.

Oct 29: STRANGE! I turned on computer and red X appeared beside wifi signal. Yet emails still downloaded into Outlook and websites loaded up. So the icon was incorrect.

Oct 30: more strange activity: started computer and this time the wireless icon read normal showing connectivity but no internet access - could not access websites or download email. So I disconnected from the wireless network and the red X showed up beside the icon. Then I was not able to reconnect. Then within 10 minutes it connects on its own.


* Dell Latitude D600 Laptop running Windows XP and Service Pack 3.
* Also running: ZoneAlarm firewall, Symantec Antivirus.
* Lyknsys Wireless G 2.4 GHZ router is in the same room as the laptop and showing full strength.
* My ISP is showing everything is normal and no service interruptions. Technician tightened a loose cable connection in my house.
* Other laptops in the house are not experiencing this issue.
* Ethernet port hasn't worked for years. LAN Card not showing in device manager & unable to resolve with Dell technician. I don't this these two issues are connected though.


1. Click "connect" to wireless network manually.
2. Disconnect and re-connect to WiFi.
3. Repair network connection.
4. ipconfig/release & renew
5. Installed the Dell system software for my model.
6. Updated the chipset
7. Uninstalled the WLAN card driver and re-installed the latest driver
8. Updated the BIOS driver
9. Scanned PC with Malware Bytes and removed 2 malicious items from registry.
10. Scanned PC with (older versions) of Spyware Doctor, Spybot Search & Destroy and no big issues.
11. Ran CC cleaner: cleaned out files and cleaned up a pile of issues found in the registry.
12. Shut down these programs: ZoneAlarm, SugarSync.

13. Added MAC Address but then removed it when didn't work: Start>RightClick My Computer>Properties>Hardware>Device Mgr>NetworkAdapters>right click it>Properties>Locally Administered MAC Address. Changed it from none to the MAC address of my router. Just as I was doing this but before I clicked ok the computer started to get connected to the wifi, but when I clicked ok it disconnected again.

14. Then I did this: Verify the network services setting. Click Start, and then click Control Panel. Double-click Add or Remove Programs. Click Add/Remove Windows Components. Scroll down and then click Networking Services, and then click Details. Verify that Simple TCP/IP Services is turned on, and then click OK. Close all the open dialog boxes. And clicked "Next" or "Finish" and a wizard processed the requested configuration change.

15. Under control panel, go to admin tools and then go to services. All the way at the bottom there is one that says wired and then wireless right below it. Both should be set to automatic and started.

Thanks for reading this and offering any suggestions!

- Robert

5 responses

Jean-François Pillou Posts 18707 Registration date Monday February 15, 1999 Status Webmaster Last seen February 16, 2023  
Oct 30, 2012 at 04:32 PM
GENTILR Posts 2 Registration date Tuesday October 30, 2012 Status Member Last seen October 30, 2012 15
Oct 30, 2012 at 02:52 PM
Hi Jeff - thanks for this suggestion. Can you kindly provide instructions on how to do this? I'm moderately tech savvy but still learning as I go! : ) Plus, any idea what caused this to start happening all of a sudden? Thanks - Robert
Me > GENTILR Posts 2 Registration date Tuesday October 30, 2012 Status Member Last seen October 30, 2012
Oct 6, 2017 at 12:06 AM
Thank you
Thanks Jeff - it worked this time. No I'm wondering how this change will effect me when I travel and use other wireless network. Will my PC still connect to other wireless networks automatically or do I need to do something differently? Thanks - Robert.
Jean-François Pillou Posts 18707 Registration date Monday February 15, 1999 Status Webmaster Last seen February 16, 2023   > gentilr
Nov 8, 2012 at 04:03 AM
I'm glad it worked! If you travel and use different wireless network, then DHCP will be used by default.
Maybe you should investigate further to understand why your router's DHCP is not working properly....
Hi Jeff,

Thanks for the info but I found the instructions lacking in detail and hard to follow. Here is what I did:

Manually set my IP address by clicking on wireless signal icon to see the Wireless Network Connection > Properties > General Tab > Scrolled down to Internet Protocol (TCP/IP), Clicked on "Use the following IP address" then entered this info which I got from running ipconfig:
IP Address:
Subnet mask:
Default gateway:

As soon as I did this I remained connected to my router but lost internet connectivity. So I went back and re-selected obtain an IP address automatically and I regained internet connectivity.

Please clarify the instructions Jeff. Thank you - Robert.
Jean-François Pillou Posts 18707 Registration date Monday February 15, 1999 Status Webmaster Last seen February 16, 2023  
Oct 31, 2012 at 01:41 PM
You did well, but you also need to write down your DNS settings and enter this info in the TCP/IP properties of your wireless connection.
Jean-François Pillou Posts 18707 Registration date Monday February 15, 1999 Status Webmaster Last seen February 16, 2023  
Oct 30, 2012 at 02:49 PM
Usually this kind of problem is related to DHCP, which means that the computer is waiting for the router to give him an IP address.

You should try to write down the IP provided by the DHCP and then set it manually, so that you don't have to wait anymore.
Go to device manager and uninstall the wifi and re start worked for me
bunny > rude gal
Jun 9, 2015 at 09:40 PM
Where is the WiFi thing that you have to uninstall
Jeff on Nov 25 or so the problem started to reoccur when for a few minutes after start up in the morning the PC would not connect to the internet. Sometimes manually trying to connect or "repair" would work, sometimes not. I checked the TCP/IP settings and they have not changed since I set them manually. I know it's not my wireless router because I have a 2nd laptop (much newer) that is not having this problem. Any other ideas on what it could be? I'm wondering if a windows update or some other update is messing with things?

Didn't find the answer you are looking for?

Ask a question
For me the answer was to change the router security to WPA2, as this is required for n-type wifi
its worked .thanks