Unable to reset my folders security options to default.

[Closed]
Report
Posts
1
Registration date
Monday January 7, 2013
Status
Member
Last seen
January 7, 2013
-
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020
-
Hello,

I right clicked on my 1 TB WD hard disk and went to properties .There under security , for everyone I chose certain permissions(only read). After this i noticed, that a create owner user with special privilege is also created. Thereafter when I try to access my folders in my hard disk , i am getting access denied error. Without thinking I deleted the 'Creator Owner' . Even now I'm getting the same error.
Somehow I found out that I'm am able to use those files only after the following procedure: right click -properties-security-advanced-continue: select the administrator one(the only one present)-check include inheritable permissions from this objects parent -ok..but there are thousands of files for which this is tedious as I have to do it individually because I am not able to do it on the folder. Do I have any other option? Also System Restore for that drive is off.


1 reply

Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Hello,

Try this 1

1) If all your files are within one folder then select that folder or Select your

drive.

2) Right-click on it --> Properties --> Click on the "Security" tab --> Click on

"Advanced" --> Click on "Change Permissions" button --> Now select the options

"Replace all child object permissions with inheritable permission from this object" -

--> Click on OK.

Good Luck