DELL INSPIRON 1525 LAPTOP "Left 4 Dead"

Closed
icetea - Feb 13, 2009 at 10:13 PM
 Oddjob23747 - Apr 8, 2010 at 07:44 PM
Hey ppls i need some help. I got a brand new dell inspiron 1525 laptop in november it runs just fine but i got the game "Left 4 Dead" and installed it. When i play it, the game runs and doesnt randomly shut down or anything. but the lag is horribly unbearable! u cant even play it becuz its so bad! how do i fix this! the computer meets all requirements so wtf is with this thing! plz help!!

7 replies

nialge Posts 4 Registration date Wednesday April 1, 2009 Status Member Last seen June 14, 2009 4
Jun 10, 2009 at 05:03 AM
hello,

the intel graphic adapter in inspiron 1525 isn't that powerful to run the game! You don't have enough graphic requirement to run the game!
3
ah thank you, well sorry im not too computer smart so exactly which thing should i click on at the site?
2
The Chosen ONE
Nov 2, 2009 at 08:43 AM
you should try lower the graphics to make it more better
0
i had that same problem where it would go eeeevvvvvvv vvvaaaacccccc god that was horible but try running with xp on it and what i mean by this is right clicking the L4D shortcut and hitting properties, a new window will pop up on here you should see a compatability tab then hit compatability tab at the top of it next hit the check mark for run this propgram in and go thru the list and hit windows xp aply the settings and hit ok it should work alot better with less lag hope that helps.
0

Didn't find the answer you are looking for?

Ask a question
sleeplessskater
Jan 12, 2010 at 02:59 PM
hey guys, i have a very simulear problem, i have a Dell Inspiron 545 (not labtop) and i thought i had enough power to run a game because its brand new and everything, but i have the same problem with left 2 dead 2, it just lags to the point that its unplayable..

can anyone help me! its driving me crazy
0
you probably only met the minimum requirements, which only lets you RUN the game. They never said minimum meant it would run well. Sorry to hear about that.
0
OMG I HAVE THE EXACT SAME PROBLEM!!

same laptop except got my for christmas so got it on decemember it lags only abit wen ur randomly walking but wen zombies come u cant play it laggs out too much

and towards the start of the first stage it laggs like crazy when its saying evacuate area

its like e-e-e-e-e-v--v-v-v--a-a-a-a--ac--u


sor realy bad.. u cant understand it good...

so yeah same problem so any help would be good thank you :)
-1