Expansion drive not visible 'my computer' but works

[Closed]
Report
Posts
1
Registration date
Friday February 1, 2013
Status
Member
Last seen
February 1, 2013
-
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
-
Hello,

I have a Windows 7 64bit computer and use Seagate expansion drive as my back up external drive. Everything worked fine for a year- I could see the expansion drive in 'my computer', could back up data into the expansion drive with no problems and safely remove the drive using the safe to remove icon.
But now, I do not see the expansion drive in 'my computer' nor when I am trying to safely remove it from the computer. However, when it is plugged in, I can open all the files through my C drive as if everything is on C drive. Also, the software Quicken which is installed on C drive will not open until the expansion drive is plugged in. And then if I would go into 'my computer' to see if the expansion drive is plugged in- it still does not show. It seems, the expansion drive has become a part of the computer and now when it is time to back up the Quicken files or anything else, the computer looks for another drive to back up the data!

Please help me find the expansion drive on my computer so I can use it as an external back up drive again and can safely remove it when the job is done.

1 reply

Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
43
Hi jas709,

This could be a problem with the Windows File System. Try to assign a drive letter to the Hard Drive from Disk Management console. Check the link below to find steps on how to assign a drive letter to the Hard Drive:

https://support.microsoft.com/en-us/windows?ui=en-US&rs=en-001&ad=US

Do reply with result.