Diskette Drive 0 seek failure (error message)

 TechIlliterate -
Dell B110

About 4 mos ago my computer began to display this message "Diskette drive 0 seek failure" on a black screen at startup. When this happens the computer may or may not startup. I was told by a computer shop that my hard drive needs to be replaced. Others have said it's my battery. Does anyone know what may be causing this and what I can do to fix it?

Thank you.

40 replies

you need to press f2 then go to Standard CMOS Features, then highlight drive A. change it to none. should not have anything in there enless you have floppy drive......
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

Thank you! Worked for me today!!!!
it worked thank you
Thank you so much!!!!

Awesome! Worked on both computers! Thanks & Thanks!

I was so frustrated when I reinstalled my operating system (Windows XP Home Edition) only to find upon boot-up that I was getting the message "FLOPPY DISKETTE SEEK FAILURE". I am a former Network Admin and I spent 3 hours reinstalling, pulling the jumper on the system board, etc., etc. I finally searched the internet, and everything mentioned there I had ALREADY TRIED to NO SUCCESS!!!! I was finally so exasperated I called DELL in spite of the fact my PC was out of warranty. Thankfully the tech could hear the frustration in my voice and I told him thousands of people on the internet wrote with this same problem so this is prevalent to DELL Dimension 9150s. He put me on hold and came back with the following and it WORKED IMMEDIATELY!!!!!!!!

1) Reboot PC and hit F2 key to go into SETUP.
2) Arrow down to DRIVES and hit Enter.
3) Arrow down one space to "DISKETTE DRIVE" and hit Enter
4) Highlight "OFF" and Hit Enter
5) Press Esc to Exit
6) Highlight EXIT and hit Enter
merci le probleme est resoulu
My XP Inspiron 530 does not have the word Drives after getting into my Comos so I just exited before messing something up/
I had the same problem w/ the seek failure message, got the answer here, but had trouble finding the step-by-step instructions on the "how to" so here they are - at least for Dell Inspirons...

At Startup press "F2" to enter setup;
Arrow down to select "Boot device configuration" - press enter;
Arrow down to select "1st boot device" - press enter;
Arrow cursor to select "Hard disk" - press enter;
Press "F10" to save changes;
Select "Y" for yes to confirm saving changes;
Press "esc" to go to main menu;
- - - - - - - - - - - - - - - - - -
Arrow down to select "Integrated peripherals" - press enter;
Arrow down to select "Onboard FDC controller" - press enter;
Arrow cursor to select "disabled" - press enter;
Press F10 to save changes;
Select "Y" for yes to confirm saving changes;

Hope this helps the non-experts like me.

Thanks for all the tips, but I'm still having difficulty, as its saying that none of the things listed are not present? I have no idea what's going on..I have a feeling if I try one more time..I might not be able to turn back on my pc:S
HELP! I have a Dell Dimension C521 Windows Xp Home Edition:) Thanks In Advance!!!!!
Thank you very much! I do all of this and my dell inspiron 530 is start normally thank you again
thank you

Arrow down to select "Integrated peripherals" - press enter;
Arrow down to select "Onboard FDC controller" - press enter;
Arrow cursor to select "disabled" - press enter;
Press F10 to save changes;
Select "Y" for yes to confirm saving changes;

this step solves my problem..............
I have a Dell Dimension E521 with Windows XP Media Edition installed and I recently had an AVG screenpop up telling me I had a virus so I started a system scan. During this scan my pc restarted itself so I couldnt complete the scan and now when I try to boot up windows it says "Loading your personal settings" then if i'm lucky i'll get my wallpaperscreencome up for a few seconds and then it will go back to the user accounts screen and say "Logging Off". I have tried to run it again and reboot it but to no avail.
I have tried rebooting in safe mode, i've tried rebooting from the hard drive and the CD-Rom using the windows installation disc I originally got with the machineand I have tried the above options too but it still will not boot up.
I do have the "Diskette Drive 0 Seek Failure" message come up and it has also told me that the "Diskette Drive (B)" is corrupt.
How do I sort this and is my hard drive completely knackered?
Thanks in advance for any advice
nevermind. I solved the problem. for dell users u have change your first boot hardware to Harddisk and the go to integrated components and disable FDC.
I am not that computer smart and do not know how to do the things you are saying to do. My computer was updated by Windows XP Saturday evening. When I got up Sunday morning, it was trying to restart. When it finally did, it had this error. I have tried everything to fix it. I do not know how to get into the BIOS on XP. Any help would be appreciated. Thank you very much!
how will I do that?? please tell me in details thanks
Hey thanks. That worked!
Great tip, solved the issue, disable FDC, amazing...take care!
How do I change my hardware to hard disc
Dell dimension 4600 bios version A07 ****||PROBLEM SOLVED ||****

What I did to solve this error was go into the bios by pressing F2 at startup.
I then changed the setting for the a: floppy drive to "disabled" as I do not have one installed.

I then checked the system event log on the bottom. It stated Bios battery failure. This explained the issue.

I then changed the bios battery inside the pc by opening the side of the case and removing the little flat 3v battery and replacing it with a new one.

*** !!!!Be sure to have the computer off and unplugged for about 20 seconds before attempting to replace the system battery. Also when replacing the battery make sure you are using one hand to hold a metal part of your computer case or have an electrostatic wrist strap on to avoid electrostatic discharge and damaging your internal electrical components!!!! ***

Vista XP on Dell desktop: F2 for set-up, go "Standard CMOS Features", change Drive A: from "1.44, 3.5 in" to "None." Solves the "Diskette Drive 0 seek failure" problem.
I had the same bother and it was enabling floppy disc drive which I dont have.go to bios f2 and click on load default then go into Integral at the bottom.Click on FDC or FDS and disable it and you have cracked it
> David
Hi my name is Michael I'm a PC phone tech where I work. The BIOS stands for Basic Input/output Sytem and can be found by pressing F2 after the memory test is complete and before the Windows LOGO. The BIOS contains system preboot and configuration information, such as boot sequence, enabled or disabled devices installed on your system.
> bearguy2u
I have a dell dimension 4600 that is slowly coming back to life after blue screen of death. I go it up and going and installed service pack 3, all seems to be good except for the initial black screen. It is telling me SATA primary drive and SATA secondary drive and the primary drive 1 not found. OS install mode enabled and I have limited memory. If I press f1 key, everything works fine, but the process continues everytime I start up. When I press f2 and go to drive config., it tells me both SATA drives are "unknown device" and the primary master drive is a hard drive. Not sure where or how to proceed from here to get a solution? Can you please help or lead me in the right direction?

many thanks

> bearguy2u
Hi Michael, My Name is marshall is there any chance that I could get your email address due to I have an inspiron 530 and constantly having troubles with it to keep in contact if I require your technology brain due to I have no knowledge of the tech side of computer software.

many thanks

I went into Bios and I do not see anything like that
is this for my problem, or for dell??
I have 2 errors Disk 0 and Disk 1 seek failure. When I go to F2 nothing happens or F12 nothing hppens, same message w/no results. I am assuming the motherboard at this point is dead as there is no BIOS to find.
My system is not coming on and when l press F2 and F12 it is responsible it is only showing diskette drive 0 seek failure

have you fixed this problem yet because mine is doing the same can not get the keyboard to run to press f2 or f12 my usb's kick in after the bios
go into your bios and disable floppy drive, disk 0, its should be under drivers
i have a dell dimension c521, I have the same problem ,(diskette drive 0 seek failure). hit f1 or f2 , I turned it off in bio and it still comes up, went back to default and still the same . I did a full recovery and for some stupid reason I cant get the drivers to install. please help . Email Id removed for security. it was doing this b4 I started working on it
Registration date
Wednesday January 27, 2010
Last seen
January 27, 2010

Thanks a million for that simple tip. It took care of my "diskette drive 0 seek failure" problem. Sincerely Computernovice.

Check your hardware configuration in your computer. How many hard drives do you have? on your IDE Cable, the big skinny Grey cord, make sure you plug the end cord of the IDE cable to your hard drive and your CD/DVD ROM drive to your middle one and the other end to your motherboards primary IDE port(Should say on your motherboard were to plug into Primary IDE) and change your jumpers on your CD/DVD Rom to slave(Look on the drive it should say were to plug it in for the jumpers) and your hard drive you use to store your OS on to Master,|| and your other hard drive you use to store your photos and all on master also(plug this on the secondary IDE port if there isn't one, refer to step 1) and start up your computer(but remember if you have a second hard drive, use the end of the ribbon cable to your hard drive and the other to the motherboard(usually the blue part that goes into the motherboard) and it should work. if it don't tell me your hard drive configuration and I shall help you. and I think that error message shows if these steps didn't help, go into your bios and change the settings on the drives to

1:Primary Master Drive Boot Device - CD/DVD Rom
2: Primary Slave drive - hard drive
3: Secondary Master Drive - Hard drive.

if these don't work refer to this post and I will try and help you on your problem, but post your hard drive configuration and maybe some pictures of your bios so I can help properly.
Hi, Im kimo
And I have the Diskette Drive 0 Seek Failure error
my pc specifications are : Dell Optiplex 170L,1.66GHz , 512MB
I messed up my whole PC, couldnt find a engineer
But.. I've been checking the most forums and others say that my Hard Disk is broken
Can't believe that cause my PC is still reading it and I tried 3 other Hard Disk
I Hope you can help me Solve this problem?
Hey my service tag for dell is 22jm0(zero)51 just tellin you that to know the type of pc I have.. I have one hardrive in that I bought but is it possible to put 2 in? if so how?
22jm051 is my del service tag. I dont know what type it comp it is. but is it possible to put 2 hardrives in it if so how> I need help
Thanks to all...if not for forums like this my life would be a hell of a lot more difficult
Good advice ... But now the screen has gone blue and it says"STOP : 0x00000024 blah blah blah! Help
I have no clue on what could fix that. Contact the manufacture.
Hi this might happen becaue of Faulty or improperly installed diskette, loose diskette/CD interface cable, or loose power cable.Replace the diskette. Ensure that the diskette/CD-drive subsystem is properly installed. If the problem persists, replace the diskette/CD-drive subsystem. try checking it might help
Thanks bigane, my error message was fixed, but after that it goes into this black screen with just the arrow mouse on it. This started happening around the same time as the error message, what could it be?
I've tried shutting it off in the BIOS menu but then I get a bunch of other messages witch I forget what they say but after that the computer just does nothing so I have to restart the computer and turn it back on for it work. the computer runs just fine when the menu pops up and I hit F1.

I should also let you know that the computer was used by my uncle who like to vist porn sites and the computer was loaded with virus and everything before I did the the factory default restart.
I fixed mine. The board reset when I removed the battery. So I went into BIOS and set the floppy drive to disabled (because I have no floppy so it will never find a floppy upon startup). It was right on the first page of the BIOS settings.
i'm really2 thanks to you.......:p
dude you were sooo right disable you diskette ddirve, a thousand thanks
When PC boots hit F2 and go to BIOS. IF it fails to enter BIOS remove power cable from hard drive and then try entering BIOS again, it should work. (off course before removing power from hard drive shut down you PC and make sure MAIN POWER IS OFF TOO) My PC did not had floppy so I disable it. Then go to each IDE make sure they are not disabled. Then very important one like many guys mentioned above me go to INTEGRATED DEVICES. In that section make sure you disable DISKETTE INTERFACE. That should do it at least it did it for me. Sorry for broken ENGLISH.