Windows7 drivers for Intel create&share pc camera cs 330 [Closed]

Report
Posts
1
Registration date
Thursday March 14, 2013
Status
Member
Last seen
March 14, 2013
-
 thecackler -
Hello,
I got a PC webcam which was working with windows xp. Now my pc is upgraded to windows 7, but the usb camera is not recognized by windows 7.
Any solutions please!

Prasannan

2 replies

Posts
6507
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020
1,543
Hello,

Try this 1

Go to your Webcam manufacture's site, download the drivers for Windows 7

and install it.

Good Luck
1
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

I know it's that simple.There is no Drivers available at the manufacturers website.
Posts
6507
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020
1,543
Hello,
Try this 1
If you have drivers that are supported for Windows XP then try installing it in compatibility mode in Windows 7. Click on the below link and follow the instructions
https://ccm.net/faq/24611-installing-a-driver-in-compatibility-mode-in-windows-7
Good Luck
This also doesn't work
Well dear, I got same Intel webcam that is, cs330. It is working fine with windows 7. Simply attach webcam to any available USB port, of course windows wouldn't install it automatically. Now download windows XP driver for the cam. Download link
http://driverscollection.com/?H=PC%20Camera%20Pack%20%28CS330%29&By=INTEL
Double click the downloaded driver file. It will extract into windows temp folder. Open device manager, choose "Browse my computer for driver software" option. Browse for temp folder in C drive that is, C:\temp\cs330_XP and click next that's all. Enjoy your antique Intel CS330 webcam on windows 7.
And that doesn't work either!
Doesn't work for me either.

I've run it in compatibility mode for Windows XP SP 3, and as an administrator.

I think the problem lies in that I have Windows 7 64-bit and this driver is meant for 32-bit (I got it to work perfectly with a Vista 32-bit machine using the instructions provided...

But for 64-bit (even in Compatibility mode), it just doesn't work on Win7.

If anyone does actually get it to work on Win7 64-bit, please let me know what I'm doing wrong.

Thanks.