Error: Write Protected

Closed
Report
-
 dev -
Hello,
I have a USB, Kingston 8gb, and whenever i want to delete something from it, i just cant do it. it says that it is write protected. i also cant format it either. i used all these methods:

//////////////////////////////

Permanently Remove Write Protection

Step 1
Insert the USB flash drive into a USB 2.0 port and turn on your computer. Click the "Start" button and then select "Computer." Note the drive letter of the USB drive, which is labeled as "Removable Disk."

Step 2
Click "Start | All Programs | Accessories | Command Prompt" to open a Command Prompt window.

Step 3
Type the drive letter assigned to the USB drive followed by a colon; for example, type "E:" (without quotation marks). Press "Enter."

Step 4
Type "format" and the drive letter followed by a colon; for example, type "format E:" (without quotation marks). Press "Enter."

Step 5
Close the Command Prompt window when the operation is complete. Write protection has been removed from the USB drive.

Temporarily Remove Write Protection through the Drive Letter

Step 1
Click the "Start" button and then select "Computer." Right-click the icon for the USB drive (labeled as "Removable Disk") and select "Properties."

Step 2
Click the "Sharing" tab and click the "Advanced Sharing" button.

Step 3
Click the "Permissions" button to access the list of permissions. Select the "Full Control" check box under Allow for full read, write and change permissions. Click "OK" twice and click "Close."

Temporarily Remove Write Protection through the Registry

Step 1
Click the "Start" button, type "regedit" (without the quotation marks) in the Search Programs and Files box and press "Enter" to open the Registry Editor.

Step 2
Navigate to "HKEY_LOCAL_MACHINE\SYSTEM\CurrrentControlSet\Control\StorageDevicePolicies." Right-click "WriteProtect" and select "Modify." Change the Value Data to "0" and click "OK."

Step 3
Add "StorageDevicePolicies" if it does not exist. Select the "Control" folder in the left navigation pane. On the "Edit" menu, point to "New" and click "Key." Type "StorageDevicePolicies" (without quotation marks) and press "Enter." Right-click in the right pane, point to "New" and select "DWORD (32-Bit) Value." Type "WriteProtect" (without quotation marks) and press "Enter." Close the Registry Editor.

//////////////

But all that doesnt work.. i dont know what to do and that USB wasnt mine also. it worked before, but i dont know what happened, after i sent some stuff in it, i wanted to delete it but the write protected error came. its been 4 months now and i am still trying to solve this problem... can somebody please HELP!!! me.....

1 reply

my pendrive is right procateed