No sound on LCD tv with HDMI cable..Windows 7 - My Soloution

[Closed]
Report
Posts
3
Registration date
Monday July 1, 2013
Status
Member
Last seen
July 2, 2013
-
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
-
I just joined to answer the above question, as I saw that people were still struggling with this problem. It was while reading something in the original thread that gave me the insight to dig a little deeper.

My issue was that I connect my laptop to my TV using a USB to HDMI box. All of today I have been playing with software trying to get my integrated webcam to work on my Dell Inspiron 1545, only to find that it was not working owing to a loose cable. But this also became the cause of my sound problem.

I noticed that the drivers for the sound output for my speaker icon for my tv were not correct, mine had a creative .inf as the main driver which could not be right, and seemed to coincide with software that I had installed earlier in the day. I had uninstalled and reinstalled the Viewspan software but this had not worked. So I went to device manager, uninstalled the device from there, and then my system re-installed the correct driver and my sound was back!

Done

Hope that helps someone!

3 replies

Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
41
Hi fiftyg,

Thank you for your insight into the matter and for finding the fix, definitely this addresses the HDMI issue for many users.

From your post I understand that apart from the sound issues with the HDMI you are facing the problem with the webcam. I would be glad to assist you with this problem. Please let us know if you have got the issue fixed by re-seating the cable? As you mentioned, "...only to find that it was not working owing to a loose cable", I would like to know if the issue still persists.

To know more about Dell's products, services and drivers & downloads, please go to http://dell.to/YBlak6
Posts
3
Registration date
Monday July 1, 2013
Status
Member
Last seen
July 2, 2013

Thanks for asking but I fixed the Webcam.

I tried all types of software downloads before I realised that the camera was reporting as an unrecognised usb device in device manager. I removed the top four screws of the bezel on my Dell Inspiron 1545 removed the small cable and then re-sat it again. When I did this windows found it and installed the camera.

So took a few hours but fixed all of my issues.
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
41
Hi fiftyg,

I appreciate your troubleshooting efforts and I am glad to know that you have fixed the webcam problem. Please feel free to contact us if you need any further assistance.

To know more about Dell's products, services and drivers & downloads, please go to http://dell.to/YBlak6