My PS3 has no sound?

Solved
tiktak - Updated on Apr 15, 2018 at 09:13 AM
 rom - Jul 15, 2022 at 11:01 PM
Hello,

Since we moved to Malaysia, I've been having though time with my PS3, I have picture, but no sound. All cables are in tact. What should I do..? Please someone HELP!!!!!

Related:

3 replies

bionik
Posts
4233
Registration date
Thursday August 19, 2010
Status
Moderator
Last seen
August 3, 2016

Updated on Nov 30, 2018 at 12:31 PM
Greetings,

After doing some searches, I find that:

From the PS3 main menu:
  • 1. Settings->Sound Settings->Audio Output Settings
  • 2. Change it from HDMI to Digital Out (Optical). I do NOT have optical hooked up on my PS3, so if you have it hooked up, you may want to unhook it.. probably shouldn't matter.
  • 3. I left what was defaulted: "Linear PCM 2 Ch. 44.1 kHz" and 48kHz
  • 4. Right on the D pad (X selects/unselects options) to move to the next screen.
  • 5. A confirmation page, hit X to Enter, saving the changes.
  • 6. Start up a game, you shouldn't hear any sound (as expected)
  • 7. Exit the game, then go back to Audio Output Settings and switch back to HDMI. I selected "Automatic" for "method for setting the output format."
  • 8. A confirmation page, hit X to Enter, saving the changes.
  • 9. Start up a game, you should now hear audio with your game (once again). The problem is most likely caused from having switched your PS3 to a different TV for a period of time.


Hope that I will work for you

Regards.

267
that guy u helped
Sep 17, 2013 at 04:39 AM
Thank u you are a life saver XD
3
Had the same problem and that worked perfectly, thank you
2
Same issue. Played GTA V last night, worked great. Today, no in-game sound. Followed the steps above and also power cycled my AV receiver. Worked great! Thanks!
0
It totally worked. Thank you.
0
Thank you! That worked, but all I did was unselected HDMI, exited..then reselected HDMI, went through the rest of tne automatic settings saved and now im good to go. Thanks again. ( I did move to another tv )
0