Western Digital - My Passport Connected but not detected

Closed
Siva.N
Posts
2
Registration date
Saturday November 23, 2013
Status
Member
Last seen
November 24, 2013
- Nov 23, 2013 at 01:45 PM
 Meleyo png - Jul 21, 2015 at 09:26 PM
Hello,

This is the Issue
My hard disk(Western Digital - My Passport) is not getting deducted. It has bitlocker password protector
1. When I connect to my laptop sound comes from my laptop. (Usual sound when any external device is connected)
2. In the notification area USB symbol with green tick is seen, which means a hardware has been connected.
3. But when I launch "My Computer", Drive folder is not seen.

I followed your Instructions https://ccm.net/forum/affich-650763-western-digital-my-passport-not-detected#1

I can see my Drive in device manager and there is no Grey entries,and idk what is a grey entry

Help me solve this Issue

Its not working in any computer,till yesterday it was working fine

Thanks & Regards
Siva.N


1 reply

xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,969
Nov 23, 2013 at 03:26 PM
There are two parts to an external drive:
1. the USB interface
2. the hard drive itseft

In your case it looks like the hard drive has failed. WD uses standard desktop or laptop drives. It's possible to pry apart the case and replace the drive with another WD drive.

Good Luck
-1
Siva.N
Posts
2
Registration date
Saturday November 23, 2013
Status
Member
Last seen
November 24, 2013

Nov 24, 2013 at 01:33 AM
THANK YOU for you Immediate reply

Isn't there another way to repair it than replacing it?

Because when I connected it today,i left in it laptop for long time and the
BitLocker opened but when I entered the password it goes not responding
0
Why does the Hard drive failure occur? My hard drive is bought recently and am facing similar issue.
0