How to remove write-protection of USB [Solved/Closed]

Posts
2
Registration date
Friday January 10, 2014
Last seen
January 16, 2014
- - Latest reply:  Iyi - Feb 10, 2019 at 03:37 AM
I try to add or remove to my pen drive, "write-protection" message appear.
In this problem, my pen drive is not write protect because it can add or remove in other computer but only can't in my computer with window XP. How can I do this problem, please give any advice for me.
See more 

2 replies

Best answer
approved by Jean-François Pillou on Nov 30, 2018
5
Thank you
Romz Nov 26, 2013 05:23AM
Hope this will help you...
for windows only

Click start
then run regedit
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
if you can't find StorageDevicePolicies under control folder
then make some new one. Follow this steps:

step 1:
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
again and right click control folder

step 2:
select new, then click key and rename the new key #1 folder into
StorageDevicePolicies

step 3:
right click StorageDevicePolicies folder and select new DWORD(32-bit) Value
for 32-bit Operating System and select new DWORD(64-bit) Value
for 64-bit Operating System

step 4:
rename dword newer folder into WriteProtect, then double click WriteProtect
and change the value data into 0 with hexadecimal base, Then close regedit

step 5:
open my computer and refresh it 5 times without do anything to your usb, and
properly eject your flash drive

step 6:
plug in your usb again into your computer and format it using exfat instead of fat32


Now, you can use your flash drive again....

Say "Thank you" 5

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 4671 users have said thank you to us this month

Thanks kyros...
thanks...........
Thanks, lovely, kudos.
3
Thank you
there's a quick way to fix a usb write-protected error.. just make sure to copy all important files as you need to format the disk..

i don't know if it works on damaged or any other errors on usb coz my flash drive kingston datatraveler 100 g3 16gb has only write protect on it.. im using win 8.1 and I have already tried regedit, diskpart, safe mode format, and several usb tool but to no avail.. wasting several hours looking for a fix on a few months old flash drive..

download phison format and restore tool in my case i've used v3.13 I didn't try newer or other versions as my flash disk has been fixed using this one....

insert your usb flash drive.. run the app and click restore and select fat as I did but I dont know if selecting ntfs would also fix the problem..

DON'T REMOVE YOUR FLASH DRIVE EVEN IF IT TELLS YOU TO..
let the program finish and it would tell you to re-insert your flash drive after its completed.. don't follow it and just close the program, do not remove flash drive!!!

instead windows would tell that your flash drive needs formatting so format your drive and don't check quick format then start.. it will format your flash drive for about 5 or 10 minutes I didn't record the time and just browse on internet as the progress bar is very slow LOL.. after formatting your flash drive it will work normally now without the hassle of the write-protected error...
Hi, i've tried everything and cannot figure out why my USB is still write protected. My key controller can't be found using the tools on the site that phison is on as it is an Innoster controller. any help would be great!
Thanks! I have the same usb and nothing else worked!
Its work great. Thanks a lot
Perfect Tip! The only method that worked for me in my 32gb Datatraveler. Although the steps weren't exactly the same the app ended up in allowing me to go through the traditional format dialog and succeeding!
TY a lot
Thank you so much! This worked for me!