Unable to format kingston data traveler 128gb [Solved/Closed]

Report
-
 SNN_57 -
Hello,
Im having problems with my 128gb kingston pen flash drive this is the only thread ive been able to find mentioning the subject. My problem is im unable to format (fat32) flash drive ive tried the methodes above and it doesnt even appear on PTEDIT32 just my local hard drive. The flash drive is also having problems with files I copy onto it and then dont appear (not with all files) I deleted all data from it and even so it appears to have 7,856 GB use of pen drive of the 128GB total space. If any of you have any idea of what I could be able to do like reseting it or format or anything I would gladly apreciate help.

6 replies

If your drive says Data Traveler 120/128GB your problem is that the drive is a Fake. its counterfeit.
18
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2770 users have said thank you to us this month

Sounds Like you Purchased on EBAY if that the case u got counterfeit product..
Try this; worked for me:

http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm
Thank you very much for your recommendation. The "guiformat" works well for my PatriotSD64GB and KingstonSD128GB.
Posts
19674
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
6,370
You cannot format a volume larger than 32 gigabytes (GB) in size using the FAT32 file system during the Windows XP installation process. Windows XP can mount and support FAT32 volumes larger than 32 GB (subject to the other limits), but you cannot create a FAT32 volume larger than 32 GB by using the Format tool during Setup. If you need to format a volume that is larger than 32 GB, use the NTFS file system to format it. Another option is to start from a Microsoft Windows 98 or Microsoft Windows Millennium Edition (Me) Startup disk and use the Format tool included on the disk.
It is working good and is enhanced in VISTA. In XP and 7, is having just the problem you pointed. This is All.
It can not be formated thou XP or 7. It is auto rebuilding as you inserted in Vista PC.
If you would like to format it, in XP, you have to download by searching the HPusbformat tool : SP27608.exe, install it, and go through its menu, to format the 128gb in FAT32. I use it and work well. I move the 128gr from to one xp to another 7 or vista, it should go back to the firs same problem loosing data or hosting its data.
Still is having problem data traveler 200 ask kingston for more, if she answer, please informed me.
Friendly
John Annousakis
inkakritis@inkakritis.gr
i had a similar, problem,

but I found that through windows xp management - disc manager
i could format my drive ntfs.

will this cause any problems, as you advised fat32

n
make sure you use 2.0 usb outlet , do aquick format should work .if your on vista you could have problems .i tried it on my compaq with vista did not recognise it properly ,formated it on my asus 2months old no problems,hope this helps