CD-ROM Drive icon doesn't appear in My Computer. [Solved/Closed]

bramossjyjy 12 Posts Wednesday April 9, 2014Registration date January 27, 2015 Last seen - Apr 11, 2014 at 04:09 PM - Latest reply:  Gwenny
- Oct 22, 2014 at 05:54 PM
hi good day
can you help me please I cant see my cd\dvd drive icon anymore . I tried all tricks that I Google on the internet it doesn't help. any one with solution can assist please.
when I insert cd inside it shows that is playing on the hard drive.

thanks
See more 

6 replies

bramossjyjy 12 Posts Wednesday April 9, 2014Registration date January 27, 2015 Last seen - Apr 12, 2014 at 12:20 AM
0
Thank you
thanks oliver

i mean im using windows xp 32bit . when I switch on my computer a green light go on showing that my CD-Rom is working, but the icon doesn't show on computer .

do you understand now oliver?

thanks
bramossjyjy 12 Posts Wednesday April 9, 2014Registration date January 27, 2015 Last seen - Apr 12, 2014 at 06:15 PM
0
Thank you
thanks jack

i tried '' FIX IT'' it says it cant find my device, I did everything I supposed to do. is not helping. im thinking of uninstall ''windows xp'' as the operation is ended.

i will install windows vista or windows 7

thanks very much for your effort
jack4rall 6505 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen - Apr 12, 2014 at 05:29 AM
-1
Thank you
Hello,

Permit me to add few lines.

Try this 1

If you failed to get your CD-ROM Drive icon then

1) Click on Start --> Run --> Type devmgmt.msc and press Enter.

"Device Manager" window will be opened. Make sure that your CD-Drive is shown

in the device manager under "DVD/CD-ROM drives". If its missing then check the

connections to your drive. Try changing your CD-Rom Data Cable.

2) If you notice any yellow mark on your drive in device manager then follow

the below instructions.

Click on Start --> In search box, type regedt32 and press "Enter"

Registry editor will be opened.

Backup your registry by going to File --> Export and save the file with any name.

Now on the left side, navigate to the location

HKEY_LOCAL_MACHINE --> SYSTEM --> CurrentControlSet --> Control

----> Class ---> Click on {4D36E965-E325-11CE-BFC1-08002BE10318}

At right side delete these files if u find it

upper filters,lower filters,upper filters.bak,lower filters.bak and then restart your

PC.

Good Luck.
Thank you!

You're the only person to have posted anywhere on the internet, let alone on this site, that I unerstood! I'm not a technophobe but im not a Computer Whizz either and your method was written simply and clearly without any over complicated jargon.

So again......THANK YOU!!!
bramossjyjy 12 Posts Wednesday April 9, 2014Registration date January 27, 2015 Last seen - Apr 12, 2014 at 10:06 AM
-1
Thank you
hi jack

i follow all steps I found that there is a yellow exclamation , when I click on class and check that files, I dont have that upper,lower filter .

please help
jack4rall 6505 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen - Apr 12, 2014 at 02:57 PM
Hello,
Try this 1
Click on the below hyperlink "Fix it".
Fix it
Follow the instructions given in "Resolution 2:". Make sure you download the "Fix it" for Windows XP.
Good Luck