Wd harddrive (1TB) not getting detected

Closed
sanzip
Posts
2
Registration date
Saturday November 15, 2014
Status
Member
Last seen
March 15, 2015
- Nov 15, 2014 at 09:12 AM
R2D2_WD
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
- Mar 20, 2015 at 06:05 AM
Hello,
My Western Digital is not getting detected which was few days ago. Suddenly this was not detected and following is happening after connecting in my PC (Win 7 32 bit OS)
a) Light appearing on the drive.
b) Hearing sound from the drive.
But not detected. Please help me on this.
I have tried few ways after searching in this site like checking from devmgmt.msc. I didnt see any yellow or grey areas as suggested in posts from 2012 but no success. Please HELP

1 reply

R2D2_WD
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
152
Nov 18, 2014 at 08:49 AM
Hi there,

Could you please explain me what are those sounds you hear? Are they related to spinning or is it more like scratching noise? Have you checked if the drive is visible in Disk Management and Device Manager? If it is in Device Manager, uninstall the device, restart PC, plug the device back in and let OS reinstall drivers.

Hope this helps
0
sanzip
Posts
2
Registration date
Saturday November 15, 2014
Status
Member
Last seen
March 15, 2015

Mar 15, 2015 at 09:57 AM
This harddrive got me so thinking that I had given all my hopes to see it work .When I connect the hard drive, I hear the beep sound in short intervals. I tried the method as you said, the hard drive appears in the device manager, i uninstalled and reinstalled the drivers. But it is still the same... Some say the magnetic plate of the harddrive is crushed and wont work now...Is that true? Can you suggest other ways?
0
R2D2_WD
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
152 > sanzip
Posts
2
Registration date
Saturday November 15, 2014
Status
Member
Last seen
March 15, 2015

Mar 20, 2015 at 06:05 AM
Hi again. Sorry for my late response. I believe that you are not facing a plate crash. If it was so, you would not be able to see the drive in Device Manager. From your description, I think the problem you are facing may be related to other things and, unfortunately, it really could be a mechanical issue. I recommend you to check the drive on another PC and with another USB cable. If there is no change and you have valuable data on the drive, use a Linux Live CD in order to gain some access to the data. If you have warranty, contact the reseller.
0