After virus desktop can't connect to internet

Solved/Closed
Report
Posts
1
Registration date
Thursday March 26, 2009
Status
Member
Last seen
March 27, 2009
-
 jujubee -
Hello,

I need some serious computer help. I had a nasty virus/worm/something infect my computer because I forgot to update my anti-virus program. I updated my software and now the virus/worm/whatever is gone. It was the virus that keeps telling you that you have a virus and to download software from a site that it redirects you to, plus it will never let you on to the internet site you want to. Instead, it constantly redirects you. (I don't know if it's important what kind of virus/worm it was but I figured it couldn't hurt to tell you.)

So the virus was gone and everything was peachy-keen, or so I thought. When I tried to go online using IE this message pops up: IE cannot display the webpage. Most Likely causes- you are not connected to the internet, etc... I tried to refresh just in case it was a glitch but that did not help. I thought maybe it was my firewall, but turns on my firewall was not even turned on so that was out too. I checked my internet connections and it said I was connected. Since it was connected, I wanted to see if I could use my laptop. Lo and behold my laptop works fine. That is how I am typing this right now.

My laptop is working on a wireless network. I thought perhaps I need to reset my cable internet, router and computer connections. So one by one I shut them down and powered them back up. Still no progress. I decided to use Winsockfix XP and burned it onto a disc from my laptop and inserted it into my desktop. After it said it fixed the problem I restarted the computer to find that nothing changed. I clicked on Run in my computer and typed "netsh winsock reset" this still did nothing. I did some other simpler things but still no change.

I am about to throw my computer out the window because I can't take it anymore. Please someone help me with this problem.

1 reply

Hi,
had same problem.
Drove me mental.
Try this, I just got it to work.
Since you can access the Internet, download firefox software and burn it onto your computer.

If you already have firefox:
Open up the Internet using firefox and go to Tools, then Options.
Click on Advanced.
Click on Network.
Where it says connections, click on Settings.
It will say either:
No proxy
Auto-detect proxy.
Manual configure proxy.

Mine was set on manual proxy.
So I clicked on the Auto-detect proxy option.
Worked a treat.
I'm back online.

Note: I am not a tech guru, but I was so sick of the Internet not working, that I couldn't possibly have done any more harm. So I hope it works for you too. Because if it doesn't, I have no more ideas.
Cheers
Bowlesy13
Thanks that worked just fine.

For IE Explorer Tools-Internet Options-Connections-Lan Settings- Automatic Settings, Check automatically detect settings.
had the same problem on my daughter's computer! I LOVE YOU HAPPY7
Thanks Happy 7 you're awesome! Best advice and it worked great!
Hi, I think I have the same problem. since updating the avg anti virus program the virus seems to have gone, however it now wont let me do anything on the net ''internet explorer cant display the page'' or watever. Ive been browsing through these settings, what box do I tick?? Automatic detect settings ?? because that is empty at the moment! (on a work computer)!!
thanks happy,spent a half an hour trying to fix the problem.. what u said worked great!!!