All of my pen drives got read only

Closed
lemrac
Posts
1
Registration date
Sunday October 25, 2015
Status
Member
Last seen
October 25, 2015
- Oct 25, 2015 at 01:58 PM
 lemrac - Oct 26, 2015 at 06:11 AM
I have four pen drives of different sizes and different make which all got read only.
One of them, which is 128 GB capacity was used only once, I saved some files and the next time I plugged it in it showed that it needs to be formatted before using it, this message appears with all four of them. When I tried to format them it says they are read only.
Tried various methods which I found on the net, but none worked.
Can anyone help?

1 reply

jollym124
Posts
98
Registration date
Wednesday January 21, 2015
Status
Member
Last seen
March 28, 2017
21
Oct 26, 2015 at 12:54 AM
A first check would be to ensure that the permissions are set to allow in each category.
You would right click on the drive and select properties. Click on the Security tab and click on Edit



Under each Title (Everyone, System) be sure the first box (Full control) is checked.

Click OK. If permissions were the issue, this would resolve it.
0
Thanks for your answer to my problem. When I opened the properties of me pendrive there was no security tab like you've shown in your answer
0