Facebook Doesn't Connect on Personal Windows 10 PCs

Closed
Sleety
Posts
2
Registration date
Tuesday December 15, 2015
Status
Member
Last seen
December 15, 2015
- Dec 15, 2015 at 06:10 PM
Sleety
Posts
2
Registration date
Tuesday December 15, 2015
Status
Member
Last seen
December 15, 2015
- Dec 15, 2015 at 06:58 PM
EDIT - Windows 10, not Windows 8 (probably changes something)

At home I have three different computers, each running the same Microsoft accounts and Windows 10. Unfortunately, as of about a year ago, none of them have been able to connect to Facebook. When I try to open the site, it attempts to load for a while and then throws up an error. This happens across all the internet browsers I use - Chrome, Edge, and Firefox. The errors I get are varied: On Chrome I'll usually get ERR_TIMED_OUT, or ERR_CONNECTION_REFUSED. On Firefox I'll get Secure Connection Failed. On Edge I'll get a "Hmm, we can't reach this page."

Any ideas? Perhaps something with my system settings, or my Microsoft account?



RELEVANT DETAILS? -------------------------------------
  • Facebook connects on every other computer. In fact, one of my computers is an iMac which I can reboot in Windows or back at any time, and Facebook connects perfectly in the Mac OS, just not on Windows.
  • When I got a new, pretty high-end computer, right off the bat Facebook was unable to load. We had already connected it to my other two computers and added our Microsoft account by that point - maybe that might be the problem?
  • Google Search and YouTube often also have this problem, but only around half the time - the other half I can access them completely and without problems.
  • I've tried multiple methods of fixing the problem, only to be met with the same annoying error. Things I've tried (though I may have made a mistake; I don't want to rule it out):

- Deleting all caches
- Lowering security for Facebook
- Updating all browsers and the OS
- Disabling all add-ons and customizations

As far as I can tell it's not a browser problem, because I recently installed Firefox (importing nothing and changing no settings) and it still didn't load.

1 reply

Blocked Profile
Dec 15, 2015 at 06:39 PM
Do you have 8, or 8.1? 8 shipped with a terrible flaw. YOU MUST update to 8.1 to connect. Go and update (apply updates!~)!
0
Sleety
Posts
2
Registration date
Tuesday December 15, 2015
Status
Member
Last seen
December 15, 2015

Dec 15, 2015 at 06:58 PM
Oh I'm so sorry I put that in wrong
I'm actually using Windows 10 >.< I'll fix that
Sorry if I wasted your time D:
0