Computer turns on but no picture showing on monitor

Closed
Crysta.lynn Posts 2 Registration date Wednesday June 8, 2016 Status Member Last seen June 10, 2016 - Jun 8, 2016 at 05:25 PM
Crysta.lynn Posts 2 Registration date Wednesday June 8, 2016 Status Member Last seen June 10, 2016 - Jun 10, 2016 at 10:40 PM
I have a home built computer, it turn on the light is green, fan running but nothing's showing on the monitor. I've tried holding the button down for a good minute and plugged everything back in and it's still the same. At my old home it worked fine and I know all my cables are good as well as monitor. Just don't know why it's not wanting to turn back on. Did put a new hard drive in it though but I tested it out and it worked right before I moved. I'm not very computer savvy so any help would be greatly appreciated.

1 response

xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,825
Jun 8, 2016 at 05:35 PM
So you just moved and found the computer doesn't work?

It's probably a bad connection somewhere. I would check the main power cables cables that supply power to the motherboard.
Pull the power cable from the back of the PC before you start messing with the internals. Unlatch the power cable(s) from the motherboard and reinsert it/them. Then plug in the power cable and try to start it again.

Good Luck
Crysta.lynn Posts 2 Registration date Wednesday June 8, 2016 Status Member Last seen June 10, 2016
Jun 10, 2016 at 10:40 PM
Didn't work. :/ but the fan sounds better (no clue how just sounds better now). Yeah it just stopped working when I got here. But before I turn it on the tv just says there's nothing connected, when I turn the computer on the tv it says there's no signal. So haven't a clue what it means.
0