Windows 7 - usb drive write protect - unable to remove [Closed]

Posts
1
Registration date
Friday December 23, 2016
Status
Member
Last seen
December 23, 2016
- - Latest reply: Tabeer
Posts
69
Registration date
Thursday December 3, 2015
Status
Member
Last seen
December 26, 2016
- Dec 23, 2016 at 08:00 AM
Hello, everyone. I am running windows 7 updated to most current.
I have two separate usb drives which I attempted to use RUFUS with, to write an iso to. This process worked about 6 months ago but I lost that drive.

So today I was going to re-install windows 7 to a family members computer but I needed an install disk. I attempted to use RUFUS 2.9 Portable to create the drive. Both times, the file failed to write after about 3 hours so I would cancel it. These drives are no longer usable and are now marked as write protected. I have tried many many fixes out there which exist for write protected drives but none have worked.

I have edited my registry. I have tried right clicking the drive to format (says it is write protected). I have tried running USB Disk Storage Format Tool 5.3 and the one by HP , both failed. I have attempted entering diskmgmt.msc but this fails to list the drive (but it shows up in windows explorer under Computer. I really have no clue what else to try. I am going to continue to try to look for solutions but I am looking for suggestions. I have used two separate usb drives by separate manufacturers. I am guessing if I continue to use other drives, they will continue to "die" since they are now unusable.



See more 

3 replies

Posts
3615
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
110
0
Thank you
Hi Boomhauer,

So basically, whatever drive you connect to that PC, it shows error message and it not possible to use it even on other PCs. Is this right? It is strange that the drive is listed in Computer, but is missing in Disk Management. Are you trying to install Windows on a laptop PC?
In general, it is possible that a damaged port causes trouble but in most of the cases, a USB drive damaged by a faulty port is not recognized at all. I strongly recommend you to reinstall the USB hubs and to seek updates for the USB drivers.
If you wish to try and save those drives, I would recommend you to connect them to a Linux PC and try to format them there. If you have no access to a Linux PC, download a Linux Live version. Most of them are free and no installation is required.

Hope this helps

Posts
51376
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
October 29, 2019
13103
0
Thank you
Click start
then run regedit
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
if you can't find StorageDevicePolicies under control folder
then make some new one. Follow this steps:

step 1:
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
again and right click control folder

step 2:
select new, then click key and rename the new key #1 folder into
StorageDevicePolicies

step 3:
right click StorageDevicePolicies folder and select new DWORD(32-bit) Value
for 32-bit Operating System and select new DWORD(64-bit) Value
for 64-bit Operating System

step 4:
rename dword newer folder into WriteProtect, then double click WriteProtect
and change the value data into 0 with hexadecimal base, Then close regedit

step 5:
open my computer and refresh it 5 times without do anything to your usb, and
properly eject your flash drive

step 6:
plug in your usb again into your computer and format it using exfat instead of fat32


Now, you can use your flash drive again
Posts
69
Registration date
Thursday December 3, 2015
Status
Member
Last seen
December 26, 2016
13
0
Thank you
1. Create a system restore point first and then press Windows Key + R combination, type put Regedit in Run dialog box and hit Enter to open the Registry Editor.
2. In the left pane, navigate here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

3. In the left pane of this location, right click Control key and select New -> Key. Name the new sub-key so created as StorageDevicePolicies. Now come to the right pane of this sub-key i.e. StorageDevicePolicies, right-click and select New -> DWORD Value. Name the newly created DWORD as WriteProtect. In some cases, you might find that this DWORD under the sub-key already exists and the DWORD has a Value set to 1. Double-click on the DWORD to modify its Value data:

4. change the Value data to 0 from 1. Click OK. Close the Registry Editor and check if the issue is resolved, else try FIX 2 mentioned below.