Asus X53u cannot boot after bios update

Closed
samclef
Posts
1
Registration date
Tuesday January 10, 2017
Status
Member
Last seen
January 10, 2017
- Jan 10, 2017 at 04:42 PM
 Blocked Profile - Jan 10, 2017 at 05:10 PM
I am samuel typing from nigeria.i have an asus laptop x53u-sx101v with 4 gb ram,but out of the 4 gb ram only 1.60 is usable and it makes the computer so slow.i searched online for the reason and found out that it is because my bios is out of date.i ran an update for the bios and it updated properly and asked me to restart my machine for the update to take effect and that was the last i saw anything on the screen.i have tried so many solution i will find on the internet but all was in vain.
I have removed the battery and try powering the pc on without the battery.as am making this post now the only response i get from the laptop is that the light on the power button is on and thats all.
I have tried all form of key combinations but all in vain.plz i need help.i have also tried pressing scroll/insert button but no show.plz am so much depressed with thos development and what makes my condition miserable is that i dont have money to give any technician.so i absolutely depened on the help from u guy.thanks in advance

1 reply

Blocked Profile
Jan 10, 2017 at 05:10 PM
Well, you should be able to flash the BIOS again, just use the file that was in place before you flashed it! Use the same source for the BIOS, and get the version earlier than that one!
0