Public internet works for everything but browser

Closed
gabrieldpg Posts 1 Registration date Monday May 29, 2017 Status Member Last seen May 29, 2017 - Updated on May 30, 2017 at 06:45 AM
Ambucias Posts 47357 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 - May 30, 2017 at 07:15 AM
Hello,

I've been having this issue for a very long time now so I've tried all solutions from page 1 to 10 on google and nothing works...

So I'm having difficulties connecting to my university internet. Internet at home and other places works fine, nothing wrong. I have used the university internet before without any issues, problem started by mid semester...

What is happening is: everything works, I often use Skype and even download torrent (only to test hehe) but whenever I go to a browser (tried Chrome, Explorer and Edge) the page often starts loading, sometimes some aspects of the page manage to load but it suddenly stops.

I can use the same wifi connection in my phone and my brother's laptop with no issue.

I have just now done a network reset as a desperate move to see if something happened but, as expected, it didn't fix the issue.

I'm working on a HP computer with Windows 10 Pro 64-bit operating system.

Please help!

I've tried at least 10 different cmd codes and nothing btw.

Thank you.
Gabriel Groff

1 reply

Ambucias Posts 47357 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 11,211
May 30, 2017 at 07:15 AM
Hi

Try resetting your browser to default settings.
0