Blank Monitor, keyboard and mouse gets power.

Closed
SiddBorah Posts 7 Registration date Friday July 14, 2017 Status Member Last seen July 14, 2017 - Updated on Jul 14, 2017 at 01:22 AM
SiddBorah Posts 7 Registration date Friday July 14, 2017 Status Member Last seen July 14, 2017 - Jul 14, 2017 at 10:33 AM
My CPU turns on and keyboard and mouse are receiving power too but the monitor remains blank. My computer all of a sudden decided to freeze up, and upon restart, the monitor won't get a signal, the light stays yellow. All the other components appear to be running fine, all fans spin. I've tried two monitors on it and I've unplugged and rearranged the RAM, and still nothing. Everything is plugged in well. So, I don't think that can be the problem. I've tried clearing CMOS, but it still didn't work. How do I fix this?

1 reply

Blocked Profile
Jul 14, 2017 at 08:42 AM
Is this an ONBOARD video, or an external video card, with what kind of connection (VGA, HDMI)?
0
SiddBorah Posts 7 Registration date Friday July 14, 2017 Status Member Last seen July 14, 2017
Jul 14, 2017 at 09:05 AM
VGA
0
Blocked Profile
Jul 14, 2017 at 09:07 AM
Onboard video?
0
SiddBorah Posts 7 Registration date Friday July 14, 2017 Status Member Last seen July 14, 2017
Jul 14, 2017 at 09:43 AM
Yes
0
Blocked Profile
Jul 14, 2017 at 09:49 AM
If the on screen menu works on the monitor (press the menu key, does another menu come up?), the next thing to check would be BENT pins on the VGA cable. Take the cable from both the monitor and the PC, and inspect that all of the PINS on the connectors are vertical. If not, then GENTLY (you will break them off) bend them back to an upright position.

Give that a try!
0
SiddBorah Posts 7 Registration date Friday July 14, 2017 Status Member Last seen July 14, 2017 > Blocked Profile
Jul 14, 2017 at 10:09 AM
No the on screen menu isn't working and I checked the VGA cables too, they seem alright. What should I do now?
0