Laptop sound on TV with HDMI cable [Solved/Closed]

Jen - Mar 20, 2009 at 11:05 AM - Latest reply:  aakash
- Nov 7, 2017 at 09:27 AM
Hi,

I have my laptop hooked up to my HDTV with an HDMI Cable. The picture is great but the sound only comes through my laptop. How do I make it come through my TV?

Thanks

See more 

134 replies

Loadedgun28 - Apr 24, 2009 at 06:07 PM
+1079
Helpful
56
I take it you are using your laptop to watch DVD etc on your HD TV. I had the same problem where the sound was coming out my laptop. I solved this by going in to the sound options on my computer (which you can access in your control panel) then set your sound default as HDMI. This should solve the problem, just remember to set the default back to the laptops speakers when you are finished using it on your TV.
I hope that helps.
Was this answer helpful?  
If the sound does not work proberly right click on HDMI and select "Properties" That should open up the properties:) Then go to the 3rd tab and make sure the sound icon doesnt have a little "block" sign!
woooow, thank u so muchhhhh, very very easy solution
thank u thnak u thank yooooooooooooooooooooooooooou
dozy11 1 Posts Thursday October 25, 2012Registration date October 25, 2012 Last seen - Oct 25, 2012 at 02:33 PM
thank you sounder, my monitor sounds better now :-)
Thank you, I love you so much rn.
+317
Helpful
you can get disabled playback devices such as hdmi or whatever else your computer has by opening the playback devices and right clicking in the space in the box and click 'show disabled devices.
+244
Helpful
ALSO!

After you go into "Manage Audio Devices" make sure you right click in that window,

then select "Display disabled devices"

That way the HDMI option will show up.

Then select HDMI, and click on "enable"

Close any audio output programs,

Then reopen and play them,

Wa-la! Sound from an HDMI cable. AWESOME!!
+87
Helpful
I dont know whether you guys have tried this but it works for me. Try :

control panel-device manager-system devices-high definition audio controller.

Enable it. In my case I have 2 high definition audio controller. Disabling one of it will disable the pc speaker & digital audio/spdif. Disabling the other will disable the ATI HDMI output with the tv icon. Enabling both will enable all sound playback device. You can actually open the sound playback device window and see the icon comes and goes as you play around enabling and disabling the audio controller.

Give it a try. Just sharing what works for me
+62
Helpful
I dont have the HDMI option in the sound .. I have two option
1. speakers and
2. SPDIF interface

then how can I enable the speaker of the TV through the laptop ?
Know it all - Feb 17, 2010 at 02:06 PM
+55
Helpful
OK for all you needs to know.

Connect the HDMI cable to the Laptop and the TV. Make sure the TV was OFF then Power it on so that the TV will then SEE the HDMI connection.

On the Laptop go to Start > Control Panel > Sounds > Right click on the "Digital Output Device" and set it as default. Depending on your Laptop will make the difference as to the name the HDMI device is under.

THIS IS the catch 22... some Laptop require you restart them after you save the changes, lol....

So while the HDMI cable is STILL plugged in and connected to the TV >>> restart <<< your PC.

Oh and something funny about Microsoft, sometimes you have to play sound in Windows Media CENTER before it will play sound through Windows Media Player.

If that fails... CALL YOUR LAPTOP MAKER, They have Tech Support for a reason
+22
Helpful
7
I followed these steps (setting the HDMI as the default) and now there is no sound period. It is not coming through the laptop or the tv. Any suggestions?

I find this most frustrating because the sound came through the tv the first 10 or so times I hooked the laptop up to it w/ the HDMI cable....
YouginB > GeekGrrl - Nov 2, 2009 at 09:16 AM
Hi guys! Any news?

I've got the same problem. I'm trying to connect my Samsung r70 laptop (Windows 7 on board) with Philips 8404.

When I choose HDMI as a primary output audio channel the TV starts to play sound from ANALOG channel (tv tunner). I wasn't able to find on where to choose an audio source.
danny > rkd993 - Dec 3, 2009 at 03:45 AM
thank you so much!! it worked!!
Hi,

Just wanted to say, this at last allowed me to select HDMI Output as "default" in the sound menu of the "Control Panel" under Vista on my Toshiba laptop (wouldn't let me do that while the "Realtek HDMI" driver was enabled... and this is indicated everywhere as the first step to solution.
Sound still not playing via HDMI cable on my Pioneer amplifier but this has been the frst progress I managed in 2 days, thanksomuch !
Worked!!! Thanks so much!
angelo > rkd993 - Feb 19, 2010 at 12:52 AM
Yes!
Thank you very much!
i have windows 7, I just update my driver, and Your driver is up to date. after this I go back and got ATI HDMI Output like default device.
If I have to go back to laptop speakers I just switch default.
Easy!

Thank you again
+17
Helpful
3
HDMI is a technology before its time during its time. It's had several modifications, including 1.0, 1.1, 2.1, 3.1 and so forth. While the video quality has always been 1080p, the audio has undergone several changes during the years.

It's possible that the HDMI port on your laptop isn't designed for audio at all. I would recommend looking for an optical, or try jacking your stereo up to the line out. Even if you were somehow successful getting the audio into your tv, HDTV audio is poor at best.

Extend a splitter cable from your headjack to the stereo with the red/white cables. it'll do you well, and most receivers can pro logic ii the audio to make it come through 5.1 quality (or comparable)
I think this is the problem I have. But my laptop is brand new, literally bought last week, surely it should support HDMI audio?
When I go in to my sound settings on Windows 7 it says that the ATI HDMI Output is not plugged in and so I don't have the option to set it as a default device. So it seems like it should work but it is not recognising the cable?
I dunno.. If you could help that would be great.
exactly the same thing thats wrong with mine
I just opened my volume control, then clicked on mixer. then on the left part of the mixer there was a scroll down box and I just kept changing the device until the sound came out of my tv.
I have a Dell inspiron laptop btw.
+13
Helpful
I solved my problem after 3 hours of screwing around. This arose after upgrading from Vista to 7.

Problem - hdmi wasn't showing up under devices for audio output. I reinstalled every driver individually that had to do with audio or video. Nothing worked.

Solution - I eventually downloaded the entire new chipset direct from intel and reinstalled the chipset and all hdmi/graphics drivers from that download. After restart it worked fine. Also needed to download newest itunes, but that worked too.

Hope I helped someone.

ps, I have a Sony VAIO FW-170J
+9
Helpful
28
Hey guys,
I just figured this out!

If you have sounds already playing on the laptop, then you must switch your default to the HDMI then go and re open the program ie itunes. Any other program playing sounds on ur laptop speakers will continue to play through the lap top speakers...

On VISTA do this
Right click your screen
go to personalize
on the left there is an option "connect to a projectror or external display"
Click the speaker picture, and set the default to HDMI by right clicking it and selecting make default.
Close your media programs, and then re-open them and hit play..

Presto! Sound will work!
This wasnt listed in my manual either I had to figure it out.
HOPE this helps, any questions email me.
Email Id removed for security
i dont have the hdmi option on a mac
thanks.. really appreciate ur knowledge:)
dude u r toooooooooooooo good, I would like to salute you,
it won't let me set hdmi as default.. what do I do?
Thankyou so much, this worked straight away. I had been trying all day with the HDMI cable and a guy at the store told me it would never work without an extra audio cable,which I bought.....but even that didn't work. Now I only need the one hdmi cable, thanks again
+7
Helpful
Blue Ray movie, Hdtv trough hdmi laptop to external Lcd flat screen tv - no sound problem.
Solution:
1. Pause the movie
2. restart the computer
3. Hit play movie (in some cases, you'll have to turn off/on the tv)
+7
Helpful
5
I finally can figure it out how to get the sound to my LCD TV. All you have to do is changing your laptop screen resolution. Change it to the higest. First, it was @ 1280 x 720. When I changed to 1280 x 800, bummmp...sound went through. Good luck all.


TDLai
Hi, I contact sony support, and I finally got my problem SOLVED!,
INSTRUCTIONS:
1.- As it was told before, get the image only playing in the TV (NOT in the laptop display).
2.- Go to sound icon in the task bar (lower right) click right button, choose playback devices
3.- Mark DIGITAL OUTPUT DEVICE (HDMI) and click in the PROPERTIES BUTTON
4,- Choose SUPPORTED FORMATS tab
5.- UNCHECK: - DTS Audio
6.- UNCHECK: - Dolby Digital
7.- UNCHECK: - Microsoft WMA Pro Audio
This worked for me watching Blue Ray with InterVideo WinDVD BD for VAIO
Hope it works!,
Thanks,
Gus
Hey man it worked! I can not thank you enough. I have a HP, this should solve the problems for all computers. I reccomend all try this first!!
khop > ssenator00 - Feb 26, 2010 at 10:04 PM
This worked great!!! I have been driving myself crazy trying to figure out why I couldnt get sound I have a brand new hp and your solution worked perfectly!!! Thank you so much for your help!
This is the fix. Tech Support couldn't figure it out, but you did my friend. I have went through all of the above options with no luck at all. Thanks again! Avatar in Blu Ray is AWESOME!
Absolutely wonderful. No geekspeak either. It still worked when I changed screen res. back again.
Dale.darkone - Apr 18, 2010 at 05:16 PM
+6
Helpful
turn on hdmi input on tv. leave Tv on and shut down the computer plug in Hdmi cable to computer then restart the computer. the sound will work to the tv
+4
Helpful
I solved this by opening PowerDVD and from the menu going to :
Settings->audio settings->speaker environment. It was set on "2 speaker". I selected "HDMI" from the pull down list. Sound now came only from the TV. I'm paranoid so I don't turn the computer or the TV on until the HDMI cable is plugged in. Remember to put the setting back to "2 speaker" before you unplug the HDMI cable after watching. I couldn't open PowerDVD afterwards when I forgot this step.
+4
Helpful
HDMI is not the problem, right click on your mouse or pad, go on volume (it's between your time and volume) you have 3 option playback, recording and sounds. You need to go on Playback den disable speakers, enable HDMI output then enjoy :)
make sure you reverse the way things were (disable HDMI OUTPU AND ENABLE SPEAKERS) otherwise further problem in the future please try not to leave the way things are like for example remove the hdmi cable out of laptop.
The Net Buff ! - Feb 20, 2010 at 02:30 AM
+3
Helpful
After trying it many times with different laptops and different browsers and different LCD, I have figured out that at times you need to restart the browser before LCD would play sound from the browser after connecting with HDMI. I prefer to use Mozilla firefox as it has adblocks addon. And even when you take out HDMI, then again you need to restart your browser to resume the sound.
Hope it helps
+3
Helpful
Try manipulating the video player such DivX. You should be able to find a sound setting option (could be in preferences, options, tools, etc.) From here you can check the sound option on or off. Try a couple of times if it doesn't work the first time.
+1
Helpful
Open your sound playback devices area in windows 7, right click and enable HDMI, if you dont see it its because yoou have the disableds hidden, show all then enable it.
+1
Helpful
yeah my desktop I just got has an hdmi port as well but when I was trying to get sound it would only come from my computer speakers. I eventually figured it out. I made my tv an extension of my monitor thru the graphics controls after I got the tv up I just had to restart my computer with the setting with tv still on and then it finally gave me a sound option for the tv under the sound control panel. set that to default and then u can go back and forth between sounds but u can not get to seperate audios like one for tv one for computer.
+1
Helpful
If you don't have a HDMI, and you are using a s-video cable, then you need a audio cable that would be able to hook up from your laptop to your TV.

This is a picture of what a audio cable would look like: http://www.ust.hk/itsc/classroom/notebook/photo/cable_audio_pc.jpg
http://farm4.static.flickr.com/3461/3811864344_f00dea631f_o.jpg

Those audio cable can be purchase in Walmarts and other superstores. It should cost around $5-$25 depending on the length you require.

I hope that helps you guys. :)
1 2 Next
Laptop sound on TV with HDMI cable - page 2