Acer Aspire one 3G - "Radio is Off"

 jeremy green -
Hello, I bought this Acer aspire with built in 3g (Umts) modem and the first 2 weeks it did service without any glitches whatsover,

Problem started when I took out my sim card to use it with my other 3g modem (usb dongle) to enjoy surfing in front of my 22 inch screen.
So, when time came to hit the road again I swapped the simcard and popped it into the Acer again, only to find out a couple of hours later that the moden refuses to connect. It gives me a message "The Radio is Off" . I assume that meant by that is the radio transmitter that sends the signals to the nearest umts station.

So, of course I went into the system looking in to every corner, checked all properties and desperately looking for the magic switch to turn on the f-g "radio" . Finally I did a full system restore with the Acer eRecouvery partition, still nothing. The Radio is off . Went out to the www and found nothing that resembles to my problem.

First one to answer will receive a big moist virtual kiss.

/Thanks in before hand

10 replies

I had the same problem with my computer, but then I found this from another site, worked for me, hopefully works for you too:

The hardware radio control switch is the manual switch that would turn on or off your wireless devices. With your laptop it should be in the front panel of the base, the part that is facing you. The first one is for your bluetooth and the second one is for your wireless card. You should be able to slide that and turn it back on.

Hopefully it works...
Registration date
Tuesday March 17, 2009
Last seen
July 16, 2009
Normally you should go on your BIOS to re enable it again! This may be happened when you removed the sim card!
I have an Acer Aspire (maybe 4 years old) and it has a switch (button) just to the top left edge of the keyboard that turns the 'hardware radio' on and off. When it is off I also cannot connect to wireless wideband. Actually there are 4 buttons lined up along the left side of the keyboard and it is the top one. Have seen some other posts that say the switch may be on the left side or front panel.
I know this is almost a year old, but I searched for hours on how to fix this problem for my acer. I can NOT believe it was as simple a fix as taking out the battery and letting it have no power for 2 minutes.

Thanks so much for the suggestion as that was the one that worked for me.
bo_mer . Thanks for you´re reply :-) I was totally convinced that you came with the right solution... Until I discovered that my Bios sucks :-(

There is no meny for manipulating "Radio Off" or for any of the other wireless stuff.

Back to status quo...:-(
I also get this Radio Off error when trying connect on the 3G network on my Aspire One. I worked OK for three months then suddenly stopped working. Any other comment idea. My BIOS does not seem to be able to controll the radio.

Any input is appreciated!!
> GrooSweden
I´ve done hours and hours of research on the net - and found no cure. Acer´s customer service refuses to answer, or they dont know the fix. I ´m beginning to suspect that the hardware is broken.

I´m trying to figure out how I could replace the 3G transmittor card. Otherwise the Aspire one works flawless. and I like to keep it. At this time it works perfectly with my external 3g Dongle.
> Dreadlock
Thanks Dreadlock for your quick reply.
Seems I will try Acer customer support again. Maybe I am in more luck than you.
I keep you posted!
how to get 3g and wifi at the same time on the acer aspire
i had a problem similar to this on my acer aspire one with my wireless adapter not connecting to networks that were in range. My solution: try unplugging the computer from the wall outlet and taking out the battery for about two minutes or so and then plug everthing back in and try it. Im guessing that it is either the sucky bios isnt fully resetting to its defaults when the computer is turned off, or the hardware is hung up and the only way to get it back to norm is to let all power drain from it and give it a fresh start. Let me know if that works for any of you!

First - thanks Andy !

Well, I charged the battery, removed the battey and popped in the SIM-card into the holder and waited 1 minute before I snapped the battery back in place again.

The login to my Internet provider appeared and Ii entered my PIN. Message came : Not Found [0x84010016] BUT the indicatorlight for the 3G connection lights up ! And the I´m connected !

So, because I dont trust computer stuff, I did the same procedure again, just to simulate everyday life because I must have the SIM-card for other purposes.

I removed the battery , took out the sim and waited a minute, then I popped the sim back again and battery too. Gives me the same : Not Found [0x84010016] , this time not connected and the infamous "The radio is Off)

At the same time the wireless works fine, I have a bunch of (Unprotected) networks to choose from. But thtas not what I want.

So, I dont know anymore. Maybe the Message: Not Found [0x84010016] is a next step to the solution. Maybe I try to post it to Acers customer support. Then we´ll see.
> Dreadlock
well it sounds like some progress.. You should know that the there have been several update releases for the BIOS on the acer website since (at least) my model has come out. You might have some luck if you flash it to the latest version.. other than that IDK what can help. Good luck
Thanks. Taking out the battery worked for me.

Thanks for Gunthet. I has the same problem ... The switch was off
And, Sarah, I noticed that putting the battery in and taking it out turns the radio off and on. I believe that is because of the 'Power Options' preferences in the Control Panel. Some things are normally (in default settings) turned off to save power when switching to battery power.
The issue with the "radio off" is now fixed. All is o.k. with the latetst BIOS update (Get it from Acer) and the manual 3G - Wifi switch located on the right side down acts normal now.