No signal to keyboard, mouse and to monitor

Lefteris923 9 Posts Thursday August 9, 2018Registration date August 13, 2018 Last seen - Aug 9, 2018 at 11:33 AM - Latest reply: Lefteris923 9 Posts Thursday August 9, 2018Registration date August 13, 2018 Last seen
- Aug 13, 2018 at 07:22 PM
So today my pc turned off suddenly and im not sure why. It has done it before but i thiught because its summer i would clean it up from the dust etc and it worked somehow. This time i've tried almost everything but no results...It boots but it does not send any signal to the keyboard, the mouse and to the monitor!
  • I've tried cleaning up the ram,

Getting the power cord off and pressing the power button for 30-60 secs,
Done the thing with the C-MOS
Please help me <3
See more 

Your reply

14 replies

ac3mark 10480 Posts Monday June 3, 2013Registration dateModeratorStatus September 18, 2018 Last seen - Aug 9, 2018 at 04:32 PM
0
Thank you
OK, if this is a PC take the ram out (you already said you cleaned it, right). Boot it without any RAM. Does it beep, or flash lights? If no, then MB is fried, as it should POST and detect that there is no RAM.
ac3mark 10480 Posts Monday June 3, 2013Registration dateModeratorStatus September 18, 2018 Last seen - Aug 11, 2018 at 12:28 PM
Try it in another PC.
Lefteris923 9 Posts Thursday August 9, 2018Registration date August 13, 2018 Last seen - Aug 11, 2018 at 02:58 PM
I will asap . Wait my response soon
Lefteris923 9 Posts Thursday August 9, 2018Registration date August 13, 2018 Last seen - Aug 13, 2018 at 05:15 AM
Well, i got my pc to a friend of mine who is really in to this stuff and the only thing he tried was to change the slot of the ram stick....IDK IF HE HAS MAGIC HANDS but he made it working lol
ac3mark 10480 Posts Monday June 3, 2013Registration dateModeratorStatus September 18, 2018 Last seen - Aug 13, 2018 at 04:42 PM
Yep, the slots matter.
Lefteris923 9 Posts Thursday August 9, 2018Registration date August 13, 2018 Last seen - Aug 13, 2018 at 07:22 PM
Ik but the thing is that we have already tried it ourselves but idk
Respond to ac3mark