WebGL

Closed
chucktone - Dec 12, 2019 at 12:08 PM
 chucktone - Dec 14, 2019 at 12:34 PM
The article on "How to enable WebGL in Chrome" is out of date. The newest version of Chrome Version 79.0.3945.79 (Official Build) (64-bit) does not have the "Disable WebGL" in the list on chrome://flags/ page. I enabled "Override software rendering list", "WebGL 2.0 Compute" and "WebGL Draft Extensions" but to no avail. It is odd to me that the last time I played a particular game on FB, 12/10/19, there were no issues at all. Nothing changed as to my video card or its driver (there is no updated driver from NVidia). There was a couple of Microsoft Updates, however nothing that appeared that it would affect anything but the Windows 7 operating system. I am completely confused as to the issue preventing Chrome from initializing/using WebGL. There are no conflicts. ?????????????

1 response

David Webb Posts 3177 Registration date Monday November 25, 2019 Status Administrator Last seen May 15, 2023   6,926
Dec 13, 2019 at 02:25 AM
Hello, since the update, it would appear that the WebGL tab has been changed. It may read as WebGL Draft Extensions.

I have found this article on enabling WebGL in your browser. Here are the main steps as explained in the article:

First, enable hardware acceleration:

Go to chrome://settings
  • Click the Advanced ▼ button at the bottom of the page
  • In the System section, ensure the Use hardware acceleration when available checkbox is checked (you'll need to relaunch Chrome for any changes to take effect)
  • Then enable WebGL:


Go to chrome://flags
  • Ensure that Disable WebGL is not activated (you'll need to relaunch Chrome for any changes to take effect)
  • In newer versions, this option of Disable WebGL will not be available, you will instead have to search for WebGL 2.0 (or WebGL Draft Extensions).
  • Here you will have to change Default to Enabled in the drop down.


[Try this if above doesn't work] Enable - Override software rendering list
Then inspect the status of WebGL:

Go to chrome://gpu
  • Inspect the WebGL item in the Graphics Feature Status list. The status will be one of the following:

Hardware accelerated — WebGL is enabled and hardware-accelerated (running on the graphics card).
  • Software only, hardware acceleration unavailable — WebGL is enabled, but running in software. See here for more info: "For software rendering of WebGL, Chrome uses SwiftShader, a software GL rasterizer."
  • Unavailable — WebGL is not available in hardware or software.
  • If the status is not "Hardware accelerated", then the Problems Detected list (below the the Graphics Feature Status list) may explain why hardware acceleration is unavailable.
  • If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! To override the blacklist:


Go to chrome://flags
  • Activate the Override software rendering list setting (you'll need to relaunch Chrome for any changes to take effect)
  • For more information, see: Chrome Help: WebGL and 3D graphics.


Hope this helps


0
Hello David!

I appreciate your taking the time to post these things in your reply.Thank you! However, I have already looked at these items and made the adjustments as I had stated in my original post and they produced no resolution to the issue. I sent a message to Google concerning this and as yet have received no reply. Not sure what the issue is/could be. The only thing I know for certain is that it's an issue inherent to Chrome as there is no issue with FireFox. Hopefully Google will reply with a work around or update that will resolve this. Thanks again!

Charlie E.
0