I have no idea what category it is called?

Report
-
Posts
8999
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
September 20, 2020
-
Hi, I followed your steps to take off write protection from my usb (and I don't even know how that happened in the first place after working well all this time?) However, following those steps and the picture shown, I didn't have an option to right click on write protect as you say. It's not there? When you offer the first step, did you mean from the laptop start menu? Because that's what I did. You can probably tell I know shit all about tech but I'm trying :) Can you please tell me what to do if the write protect isn't there? (Problem: when trying to save changes made in a document I have already previously saved on my usb, it suddenly tells me its write protected and I cannot save it because it is either full, damaged or something? As far as I know it shouldn't be, I checked its not full and I know I didn't damage it so I don't know how what's happened). Help please? I don't want to lose any of the stuff I have on this usb, will I need to transfer it all to another?

Thank you in advance :)
Sara

4 replies

Posts
8999
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
September 20, 2020
1,000
Hi,

Press the Windows + R keys and type diskpart.

In Command Prompt, type list disk and press Enter. You will a list of mounted disks, note the number referring to your USB.

Next, enter the command select disk x
  • x refers to the number of your USB.


Then type attributes disk clear readonly. Press Enter.

Type exit and press Enter.
3
Thank you

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 2886 users have said thank you to us this month

Hi,

Thanks for offering help.
Can you please lay it out step by step for me, I don't even know where u started by saying 'press windows + R' ?
Yes, I am that lost with tech stuff.
:/
Can you please lay this out for me step by step like you're talking to someone who does not understand any of the stuff u automatically understand please?

Thank you kindly,
Sara
Posts
8999
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
September 20, 2020
1,000
No problem!

On your keyboard, you'll see the Windows logo key and the letter R key. Press on these keys at the same time. This will open the Run box.

In the Run box, type diskpart and press Enter.

A new window (Command Prompt) will open. Type list disk and press Enter.

You'll see a list of disks that are connected to your PC (Disk 0, Disk 1, etc). Note the number referring to your USB key. You can look at the size column to locate the USB key. Usually, the size is smaller than the computer's hard disk - MB is smaller than GB.

Type select disk x and press Enter. NOTE: x refers to the number of your USB key (Disk 0, Disk 1, etc...). Replace x by its number.

The USB key will be selected.

Type attributes disk clear readonly and press Enter.

You'll get the message "Disk attributes set successfully".

Then type exit and press Enter.

Hope this helps.
Hi there, sorry for the late response. I have had a lot to deal with lately (I have a debilitating health condition) but I have finally sat down and done what you suggested. While I seemed to have gotten through the steps fine, (it all went as you said) I have no idea if it worked - BUT I think so.... However. I think I have complicated it earlier on... meaning when I didn't know how to take it off read only as per your instructions, I recall very naively (PERHAPS QUITE STUPIDLY) going in to try to fix it by simply trying things - yes, not knowing what i was doing, hoping something works... which is when I gave up after some tries and I came here.
So can you help me with this? The problem is, when I (after doing the above and seemingly taken off the readonly) I tried to open some of my folders in that usb to check out if the contents are there, if I can see it and edit etc etc, and I can't. First thing noticeable is that the words, the names of my folders in there (the first open window, gives English written folder names that I had created ie Writing, ie Meditations etc etc... But going into a folder, ie the Writing folder, the names in there (of different documents etc saved in the Writing folder) aren't English characters, they are strange characters (there are some English letters, some foreign letters, shapes/ blocks etc., I cannot read it obviously). I don't know what I may have done to cause that and how to un-do that so that I can reclaim my folders and their contents. Is there a way forward for me here? Please help if u can, I really appreciate it! And if you can't then maybe refer to someone/ some place / suggestion? I still appreciate the help given already for the above, thank you :)
Posts
8999
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
September 20, 2020
1,000 > Sara
Okay, I saw the page u referred me to, read it, but am stuck, I need some clarification on the steps please...
How do I 'open a new text document in my flash drive?' What does that even mean? What do I do to do that? U see my issue, I don't know what the presumed info is to even get to doing the steps laid out. Could you please break down those two options that are there for me as you did previously in simple-stupid terms please? Then I can try them out.
Thank you :)
Posts
8999
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
September 20, 2020
1,000
Access your USB drive and right-click in an empty area where your files and folders are located.

Select New > Text Document. Open that text document and paste the following code into it:
@echo off 
attrib -s -h -r /s /d
cls
exit


Next, go to File > Save as. Name the file unhide.bat and save it to the USB drive. Once the batch file saved, ("unhide.bat"), close and delete the previous text document you created.

Double-click on the unhide.bat file and a black command screen will pop up and close on its own. Then, try accessing your files and folders. If can't open your documents, try disconnecting and reconnecting your USB drive.

If you still can't access your files, try the second method:

At the same time, press the Windows logo key and the letter X key on your keyboard.

In the menu that appears, choose Command Prompt (admin). When you're asked if you want to allow this program to make changes, click Yes.

In Command Prompt, type chkdsk E: /f /r /x and press Enter. (Replace the letter E by the letter of your USB).

Good luck.
Thank you :)

I did the first one, as you laid it out, and it didn't result in being able to open my files :(

My files still look jumbled. I want to send u a pic so u can see, but I don't see an option here to attach a pic? Is that not possible?


..So I got on with the second option.. but I don't have a "Command Prompt (admin)" option shown when I press the windows logo and x.. there are lots of options but that is not one of them?

Can you please help me proceed?

Thank you kindly,
Sara
Posts
8999
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
September 20, 2020
1,000
You can add a picture to your message by clicking the mountain icon located at the top of the field.

Regarding the second method, your can open the Start menu and search for "cmd". Right-click on "cmd" or "Command Prompt" that appears in the search results and choose Run as administrator > Yes.

Then type chkdsk E: /f /r /x and press Enter.
  • Replace the letter E by the letter of your flash drive.