Can't upload contacts to messenger

Report
Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020
-
Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020
-
Hello,

Where can be a problem that messenger app don't wanna upload/ synchronize my contacts from SIM card to messenger(to see which of my friends are already at messenger). How to fix it? Thx

System Configuration: Android / Opera 60.0.3004.55063

2 replies

Posts
9116
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
October 12, 2020
965
Hi,

Try importing your contacts from the SIM card directly to your phone. Therefore, if your contacts are stored in your phone's internal memory, Messenger will be able to synchronize them.
1
Thank you

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 2942 users have said thank you to us this month

Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020

Where it means directly to phone, please? I have Xiaomi 7A, and I put contacts to SIM, Google account or MI account. Nothing Worker...
Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020
>
Posts
9116
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
October 12, 2020

I tried that. But in "import from SIM card" it give me only options Google account or MI account. No other option there. I tried, also, both of them, but still no effect....
Posts
9116
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
October 12, 2020
965 >
Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020

Is Messenger allowed to access your contacts? Go to Settings > Apps > Manage Apps > Messenger > App permissions and make sure the Contacts option is turned on. Normally, even if the contacts are saved on Google, it should be able to sync them.
Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020
>
Posts
9116
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
October 12, 2020

Contacts are allowed in settings and I also tried saved them on Google. Nothing happened. All settings are same as my brother has, but my messenger "don't work" correctly.
I also allowed in Facebook settings "permanently uploading contacts". Nothing happened, too
Posts
9116
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
October 12, 2020
965 >
Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020

Close the Messenger app and go to Settings > Apps > Manage Apps > Messenger > App info. Choose Clear cache and Clear data. Next, uninstall the app and restart your phone.

After restarting, reinstall Messenger and when it asks you, give it the permissions it needs.
Posts
5
Registration date
Tuesday September 22, 2020
Status
Member
Last seen
September 24, 2020
>
Posts
9116
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
October 12, 2020

I tried this, too - several times. I also tried reset phone to factory settings, and still nothing helped. I'm really out of options...☹️