P4 doesn't boot. New PSU, HDD works

Closed
Report
-
 Gone -
Hello,

I've had a lot of trouble salvaging a P4 PC that keeps crashing. I took it to the shop and they definitively stated that the PSU needed replacing. Did that and still it crashed. I suspected the HDD. Took it out and mounted in external enclosure on other PC and copied on content off (worked well for 4 hours, and running). Replaced HDD in case and restarted. Keep getting the "Press Del to Setup or Alt-F2 to enter EZ flash utlility" but pressing either has no effect (as if the keybaord is disconnected). Repeated attempts result in the same outcome. No access to control the boot process either with a change to the Bios to boot from CD or otherwise. Can you please describe what might be wrong? I'm suspecting the MOBO but maybe the memory. I'll try the eraser on the SIMMs to clean them of static, etc. Not sure what else can be done. Any help would be appreciated. Cheers.

3 replies

Posts
257
Registration date
Thursday May 14, 2009
Status
Member
Last seen
September 30, 2010
33
hi,

try to replace the HDD cable.

since you already copied what you needed, format the computer and reinstall the operating system.

install the appropriate drivers.

this should fix the problem.
Thanks for that update.

In fact I did exactly that. I replaced the HDD ribbon cable with two separate other cables, and neither worked. Now I've wiped the HDD and I cannot install the OS without the machine working. I don't want to mess up the one I'm working on. I tried testing if the MOBO could detect if the memory was extracted and it did send the constant beep indicator. I also used an eraser on the memory SIMMs and nothing changed. I also tried dissipating the voltage by unplugging the power and pressing the on button for 60 seconds. I just keep getting the same message "Press Del to Setup or Alt-F2 to enter EZ flash utlility" and the keyboard won't do anything. Nothing has changed through all of this I'm wondering if it has a problem with the MOBO now. Here's a new question: If I unplug an HDD yet have a CD with an OS ready to install shouldn't I be able to press a button on the keyboard (like DEL)?
FIXED

Reset CMOS battery - no avail. Then changed keyboard - detected BIOS and started again. Problem solved for now. Thanks all.