HP Officejet J5780 All-in-One

Closed
Kar - Jun 28, 2008 at 04:35 PM
 TerryB - Jun 20, 2009 at 03:29 PM
Hello,

My copier will not scan. It will copy, print and send a fax, but it will not scan.

Message is An error has occurred while communicating with the scanning device. Be sure you are hooked up correctly.

I did everything correct when I installed the printer. Can you help me. I have been trying to get this to work for several months. Can not get help from Circuit City, or HP
Kar

8 replies

I finally have gotten this fixed after many, many frustrating weeks. My printer is an L7650, but this process may work for you.

First of all I had to do a complete Level 4 uninstall, which is one level lower than the HP service people initially told me. I didn't even know what an L3 uninstall was before I started this process. Since my printer is different, see if you have an L4 uninstall procedure. The Lx uninstall procedures are not executable from the standard install GUI, but rather in a subdirectory on the cd: \util\ccc\uninstall_lx.bat, where the x is the level you are going to uninstall to (e.g. uninstall_l4.bat).

But that was not sufficient. It was just the starting point. I also uninstalled all HP printer/scanner software on the systems (i.e. for any other HP printer or scanner devices) using the add/remove software control panel software (this system used to have another HP printer attached). And then I also had to go through and manually delete the Program Files\HP directory, as well as several hpq*, hpw* and hpz* files in the \Windows and Windows\System32 directory and also the referencing entries in the registry. Also I scanned *.inf and *.pnf files looking for references to HP printers and scanners. These were done more as a "hit and miss, the scanner still isn't working", "let me continue to delete files (with reboots) until all remnants are gone" simplistic mentality. A number of the hp* files kept on reappearing after rebooting (I suspect these were due to the remnants of older HP software that really was never cleaned up). When this no longer happened, I could then go to the installation process, which worked flawlessly and there hasn't been a problem since. Since this was a shared printer, this problem simultaneously happened on 3 systems, all of which were upgraded to XP SP3. All the systems at one time independently had another HP printer attached to them (but different model printers on each). The problem did not exist on any system while under SP2.

All I can say is "good luck". Other than these painful steps that I used, I have not been able to find a clean solution to this problem.
23
Ok the reason I don't have a connection is because there is NO USB port...can't believe it..I have had this printer for over a year and tried to get someone to help but no one ever would..We will see how it goes..

I know its not difficult..If I only knew where to connect the usb port from...or to..
0
I was able to use this information to reinstall my J6410 all in one in Vista. After two weeks of failure.
Or to be precise, I was able to make sure the previous installation ( supposedly level 4'd) was really cleared out.
One added detail though. In the Vista Windows\system32 folder were a few files that would not delete. Even when I'd spent hours trying to get the permissions right. And I had to boot into Linux to get rid of them. (USB bootable version).
0
Hi ya i have had my all in one now for about a year, it worked fine at first but for the last 6-7 months it wont print, fax or scan but it will copy, what is going on?
even if i try and install it again it still dont work and it didnt even come with a usb cord. if any one can help i would be really greatfull.
6
Hi there, Just curious. Will it print off of your laptop or computer? It only says "Fax Scan and copy" on mine. So I'm wondering if it prints files (letters, etc.) off of your computer. And did yours come with a USB cord? Thanks for the info. When my son gets home from work, maybe he can answer your question.
4
Got the same problem with a different HP All-In-One (the L7500 series), and it just started happening after I installed XP SP3. So far no fix, despite trying everything HP recommended, including uninstall/reinstalling HP software, etc. Very frustrating.
4

Didn't find the answer you are looking for?

Ask a question
I have been emailing back and forth with HP on my c4180. I am not sure when it quit scanning since I do not use it every day, but occurred around the time that I installed XP SP3. I have uninstalled and reinstalled the HP software ~10 times. I rolled back my service pack and sitll no luck. I don't think HP knows what is happening because they have me doing alot of the same thing in every response from them.
4
Chaps,

I too have a problem with my all in one J5780, I can print, I can copy, I can using microsoft tools, but I can scan using the windows photo gallery.......

I have taken loads of support from HP stripped out re-installed stripped out re-installed, but I am still having issues using the HP program for scanning.

I know I can scan using the Windows Photo Gallery program, but this does not let you store as a .pdf file.

Does anyone have any other suggestions.

Stuart
4
GiantLeap
Posts
85
Registration date
Saturday November 29, 2008
Status
Member
Last seen
December 8, 2008
45
Dec 3, 2008 at 02:25 PM
store as bmp/tiff or anything else and use PDF conversion software

make sure you are running HP software with recommended newly installed operating system, including service packs versions
0
My daughter has had her J5780 for about 2 years with the same scanning problem. Go online and look for an updated driver for this printer because it isn't very compatible with Vista. There is one out there because I did it about a year ago. Then when you first connected your printer, the HP Solution center uploaded too. Open that up and do an update. Now I can scan off the solution center and save them into Word, email or even fax a scanned document provided my fax connections decide to work right.

Good luck.
0
ClarkGriswold
Jul 23, 2008 at 05:22 PM
Kar:

I can only empathize. I too have been futily seeking for a solution to this very same problem for several months.
3
In my post I didn't add, Thanks AllBackjack !!!!
2