Connection keeps timing out

Solved
Kimber - Updated on Nov 29, 2018 at 02:55 AM
Jean-François Pillou
Posts
18668
Registration date
Monday February 15, 1999
Status
Webmaster
Last seen
January 12, 2022
- Nov 28, 2018 at 11:38 AM
Hey,

I'm having problems with my wireless connection, the internet works for all our other computers in my shop, but mine!! It dies out every couple of pages or so and says that my connection has timed out with the following error messages :
  • Connection timed out
  • Connection either timed out or was lost
  • Connection timeout TCP
  • Connection error timed out
  • Connection request timed out
  • Connection attempt timed out
  • Connection server timed out
  • Connection has been reset, closed by server


So to keep browsing I have to disconnect and reconnect to the internet. Then it times out after a few pages again. It's HORRIBLE!!! Every page or 2, I've got to disconnect and reconnect!!

All the while I've got 5 bars, but sometimes it says I've got 'Limited access'

I don't understand!! Somebody help me before I murder my laptop!!

19 replies

Jean-François Pillou
Posts
18668
Registration date
Monday February 15, 1999
Status
Webmaster
Last seen
January 12, 2022

Updated on Nov 30, 2018 at 12:22 PM
Hi,

Here are some easy ways to solve this issue.

The first one consists in increasing the timeout value :
  • Do Windows+R, then
    regedit
    and go to
    HKEY_CURRENT_USER/SOFTWARE/Microsoft Windows/CurrentVersion/Internet Settings
  • In the Internet Settings panel, find
    ReceiveTimeout
    and Set the value to 100*<number_of_seconds>*100. For example 1000 would give 10 seconds.
  • Save and restart.


Try to renew DHCP :
  • Do Windows+R, then
    cmd
    and Ctrl+Shift+Enter to execute as administrator ;
  • Launch these different commands:
    ipconfig /flushdnsipconfig /registerdnsipconfig /releaseipconfig /renew


Check that you don't have a bad hosts file:
  • Do Windows+R then
    notepad %SYSTEM32%\drivers\etc\hosts
  • Ensure that there aren't any websites listed.


Then, check your Internet settings :
  • Windows+R then
    Inetcpl.cpl
  • Go to Connections / LAN Settings.
  • Ensure that Automatically Detect Settings, and Use Proxy Server for your LAN are unchecked.
  • Save and restart computer.


What you can also try:
  • Try another browser ;
  • Disable your different browser extensions ;
  • Restart your router ;
  • Update your router firmware ;
  • Use Google DNS
75