The Disk Drive is stuck on my dell dimension [Solved/Closed]

Computer need helper - Aug 25, 2009 at 07:58 AM - Latest reply:  KoalaWithAComputer
- Feb 20, 2016 at 01:56 PM
Hello,
On my Dell Dimension 9100, the disk drive (the thing that reads DVD's and CD-ROMS) is stuck. It will not open no matter what I do. The light does not even turn on when I push the button to eject. I even went into my computer, right clicked the DVD-RW Drive and clicked eject, but still nothing. Please help!
See more 

6 replies

0
Thank you
Unfold a paper clip, make it look like a long bar, then insert it on the tiny hole, that'll eject the tray
Thank You. Worked like a charm.
KoalaWithAComputer - Feb 20, 2016 at 01:56 PM
Thank's so much that help so much!
0
Thank you
brilliant thanks
fea_ture 305 Posts Wednesday May 13, 2009Registration date January 2, 2010 Last seen - Aug 25, 2009 at 08:30 AM
-1
Thank you
Dear Sir,

The drive is surely damaged or may be should be well connected

You will have to send it to your vendor or a technician to get it replaced!

Thanks