Macbook drivers XP thru bootcamp [Solved/Closed]

rbhebron - Sep 2, 2009 at 03:36 AM - Latest reply:  baldissera
- Oct 10, 2011 at 01:47 PM
Hello guys,

I have an 13" macbook (the one still with the firewire port) core2duo, 120 GB HDD, 2GB RAM. Currently, i'm trying to dual boot leopard with XP thru bootcamp. My question is - can't seem to work the Macbook HD audio soundcard in XP. which HD audio driver for XP shud I get in order that the Macbook HD audio will work on XP SP3? have already got most of the devices working but wud prefer to have them all working - they are:
video card - intel GMA 950 / Mobile 945GM/GU Express Integrated Graphics Controller - now working
LAN port - Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller - now working
USB 2.0 port - now working
camera - i-sight - now working
DVD-RW superdrive – now working, using NERO 8
Firewire port - OHCI Compliant IEEE 1394 Host Controller – now working
wifi – airport express - Atheros AR5006X 802.11abg Wireless NIC – now working
sound card - intel integrated HD audio - still doesn't work
keyboard functions - ? the fn + page-up/page-down key doesn't work
trackpoint - ? the two finger scroll key doesn't work
bluetooth - ?
infra red controller - ?

any advise pls?
See more 

4 replies

Best answer
1
Thank you
Hello I have the same macbook and I download the high definition audio driver package kb888111 try to google it!
my audio in the XP OS is working!

Thank you, baldissera 1

Something to say? Add comment

CCM has helped 1664 users this month

suff954 3859 Posts Wednesday May 13, 2009Registration date September 17, 2010 Last seen - Sep 2, 2009 at 04:37 AM
0
Thank you
Hello there,

You will have to get your sound device details,

Please use the Everest software to know which driver you need to download

Get Everest for your computer:

http://ccm.net/download/download-53-everest

Install the software and scan your pc for your driver details

Thanks
rbhebron 1 Posts Tuesday September 1, 2009Registration date September 2, 2009 Last seen - Sep 2, 2009 at 09:58 PM
hello,
thanks your suggest...

everest says its a SigmaTel STAC9220 A1 @ Intel 82801GBM ICH7-M - High Definition Audio Controller. have already downloaded & installed the Intel 82801GBM ICH7-M chipset controller driver and the SigmaTel STAC9220 A1 HD audio driver separately but still no sound. perhaps i'm doing something wrong.

need more help.....
0
Thank you
hey there,
I think u need universal audio device driver (uaa) from microsoft website search for UAA download it and install it
than u will c the missing audio driver