Can't open disc C and D by double clicking

Solved/Closed
JusK Posts 8 Registration date Monday July 21, 2008 Status Member Last seen January 23, 2009 - Jul 22, 2008 at 12:30 PM
 eeswar gour india - Jan 19, 2013 at 03:01 AM
Hello, I'm new at here. I have this problem. I can't open my C and D drives by double clicking on them, instead the drive are beeing opened in my XnView program. But I still can open the drive by right clicking and choosing open. I tried removing the XnView folder from Program Files folder, but when I double clicked on my drive it automatically started Open With box! I've searched the web trying to find the solution I've tried many things one of theme were Disk Heal program I've downloaded it, installed it, run it and red the instruction, the first three lines sad:
"1)Fixes Disk Problems:

Fixes the "Open With" Dialog or "Could not find 'something'" error
which occurs when a drive is opened."
But when I tried to fix it nothing worked. Maybe I did something wrong with the program, maybe it wasn't programs fault after all.
On the web I found two possible reasons: 1 Anti-Virus program deleted autorun file with the virus.
2 It happened because of drives icon change @ Control Panel>Appearance and Theme>Folder Options>File Types.
Now I know it was the second one because I tried to change the drives icon(it didn't work,but in the file type wen I pressed the advance button it showed me that the icon is changed.). I changed the icon beck but still nothing. I'm telling you all this too give you as many information as possible.Ask me if you need more information! Sorry if I've confused somebody.
So that's my problem! Please HELP ME if you can! I'll be VERY grateful for any HELP! Sorry for English, I tried!

53 replies

thks so much .. it workd
1
one more solution:

first go to run then write " regedit" that is registry

then find " ctrl+f"

in this box write "mountpoints2" and delete it ......

then again press "ctrl+f" again find mountpoints2 until all these files are not deleted

then u will see ur problems is solved................




THIS SOLUTION HELPD ME ..ITS QIUCK ND EASY ..TRY IT IF U NEED HELP.........
THNX manmeet bhatia xxxxxx
1
thx man, this solution was only that worked for me :)
0
Great.. Friend I'm trying to solve this one from the morning and now it is 10 in the evening. Finally U R my computer's saviour... Cheers God bless U
0
How do I enter the thing in command prompt?
Start --> Run --> cmd?
so do I do
c:\> attrib -r -s -h autorun.inf
[Enter]
c:\> del autorun.inf
[Enter]
d:\> attrib -r -s -h autorun.inf
[Enter]
d:\> del autorun.inf

OR
Just type the thing in whole? Help?!
0
Thank' a lot ravi.
so masterful!!!
0
Wonderful! This worked for me. By the way, I got the "cannot find autorun.inf" message as well. What I did was move up to my root.

For example, I was at

C:\Documents and Settings\Dave:

I moved up by using:

C:\Documents and Settings\Dave: CD..

and then:

C:\Documents and Settings: CD..

That put me at:

C:\

Then I was able to use the original commands with -r -s -h along with the deletes.

Reboot fixed the problem.

FYI, the original problem was caused by the NAR.VBS virus and XP Protection Center.

Thanks again,
Dave
0
husain > gomcse
Mar 10, 2009 at 08:05 PM
hey
i did the same thing
deleting autorun.ini
now my system is not booting
everytime it asks for user & then selecting the user
it goes off saying logoff user.
please help
0
ANISH > husain
Dec 25, 2009 at 03:38 PM
fool its not autorun.ini.its autorun.inf.there is a virus in ur pc run in safe mode use ur antivirus and delete it ur problem will be solved,if it doesnt just reinstall ur window again as u have deleted imp autorun file.else ther is
another way just mail me on anish_scorpio2006@indiatimes.com I will give u solution.
0
thanks for the tip.. it worked... nice.. nice...
0
When I Double Click on C:\ open in Direct Search Menu How to Change Open Typr
0

Didn't find the answer you are looking for?

Ask a question
heey guys...i had the same problem also n I sloved it

Thankssss But

Now, I can see all the hidden files " which are looking faint icons " whenever I enter any driver folder why? do u know what can I do ?
0
Can you Pleace Help Me ?
I link to Craet A C++ Program that Uses For Format A Disk(Flash,Hard Disk,Floppy)
Can you Give Me Adia the Working With C++ Programing
Mean Acode The Ceats As I wont.
Thanks!!
0
Deleting mountpoints2 worked. Thanks!!!!!
0
JusK Posts 8 Registration date Monday July 21, 2008 Status Member Last seen January 23, 2009
Jan 23, 2009 at 07:28 AM
HI ALL!!! Can some one please help!!! dlc72764 & obot,Please! Reade they're posts and please reply. Any help would be appreciated!
P.S. obot-you don't have to post you're message twice here,you know. Hope you'll get you're answers.
0
JusK,

I have Administrator rights. Since posting I have tried several things and all seemed to fail. As of yesterday I was still locked out of the one drive which caused the autorun.inf to replenish itself on the rest of my PC drives.
This morning McAfee ran as scheduled and all of the drives had the autorun.inf quarantined, not the case of the one drive when I ran McAfee on Wednesday and again on Thursday. I have since opened the problem drive and the autorun.inf is gone and did not replenish itself with the opening of said drive.
I have no clue as to why or how this happened, only that it did and I am very happy about it. Somehow the denied access was removed and I have clean drives once again.
Thanks for the good thoughts and I hope I never have to talk to you again:)
0
Alex - Romania
Feb 6, 2009 at 05:32 PM
Hello , this also worked for me. I deleted autorun.inf and everything was soleved. thanks a lot. My antivirus did not detect any virus, its up to date (i have Symantec full licencesed version not a cracked one) and it still did not detect this as a threat or a virus or a risk. I think this was from a flash stick that I used. Anyway thanks again.


Alex
0
thnk u man,whoever came up with this solution great share ,,,,,good work man
0
it work good FIXED.
thanks.
0
Thanks, it's work.

Kuck
0
Thank you very much ravi, you solved my problem
0
i can't open my drive c:, this message always pops up when I double click drive c: or try to open it with right click then open...

here's what the message says: "Cannot find script file C:\__.vbs"
0
thank you, Ravi. It really worked. For a novice, such as me, it was difficult to go to command prompt though and also to change from one drive to the other. Otherwise it was straightforward. Thanks once again. Syed
0
thank you very much for your tip.it works great...
0
regsvr32 /i shell32.dll worked for me but I still cant get my icons back!? what should I do
0
thanks, workd perfectly!
0
Hello,
I have tried the methods above. The one worked is to remove regedit file "mountpoints2". But after restarting my computer, the problem comes back (Can't open disc C and D by doble clicking). I check the regedit files, the "mountpoints2" file comes back again. Does anyone else see the same issue?
0