Acer spire 4730z [Solved/Closed]

affandiz - Oct 13, 2009 at 07:39 AM - Latest reply:  Paxrun
- Dec 1, 2009 at 03:20 AM
Hello,
acer spire 4730z
i would like to how to recover bios after fail update on acer aspire 4730z.
i tried to update the bios and suddenly the the power goes out.
after that notebook book wont start. when i press start button the power led turn on, the screen blank and nothing happen.how to revert back the BIOS.
i already check the display, ram and it ok.please need help here..
See more 

3 replies

Best answer
closeup22 8933 Posts Friday May 15, 2009Registration date October 7, 2010 Last seen - Oct 13, 2009 at 11:09 AM
1
Thank you
hi there,

contact your motherboard manufacturer and

ask if replacement of bios chip available

as you need to replace it

Thanks

Thank you, closeup22 1

Something to say? Add comment

CCM has helped 1676 users this month

is there any other way than that
Paxrun > affandiz - Dec 1, 2009 at 03:20 AM
Well... There is a way to get factory default for motherboard bios. You just need to unplug / take off your CMOS for about half an hour, and you will get factory bios default. But it would not work, do it at your own risk.