Laptop keyboard acting strange

MJK - Dec 16, 2009 at 08:03 PM
 MJK - Jul 6, 2010 at 09:07 AM
I am using a Toshiba laptop with VISTA and every once in a while my keyboard acts strange. Each time I hit the same key a different character appears on screen - and it scrolls through the entire keyboard. For example, if I hit the "S" key 8 times in a row I get q,w,e,r,t,y,u,i, etc. I get the same result with every key.

It happens in WORD, POWERPOINT and EXCEL but not in email. It also happens frequently when I close the laptop to put it to sleep and then try to logon. My password will not work because the keyboard is not working properly.

Does anyone know why this is happening or how to fix it? Thanks for your help.

3 responses

nomadcrys Posts 195 Registration date Tuesday November 18, 2008 Status Member Last seen January 29, 2010 48
Dec 16, 2009 at 11:27 PM
MJK, this kind of problem requires a technician to be fixed...
Thanks for the input. Can you please provide more details? Do you know what's causing the problem? What would a technician need to do to fix it?
hi MJK;
were you ever able to solve this issue? i've got the same problem at times on my Lenovo Y530. any info you can provide is greatly appreciated.
I was able to solve the problem. By any chance do you have ZoneAlarm security software installed on your computer? This is what caused my problem. To solve it, open your Zone Alarm. Click on Browser Security. Click on Adjust Browser Security. Click on Settings. Click on the Advanced Tab. Then remove the check mark from the box called "Block programs that secretly record your keystrokes".

I found this solution online and it worked for me. If you do not have ZoneAlarm it could be another anti virus/anti spyware program.

Let me know if this helps.
I had wierd action on my Toshiba keyboard too, and got it to stop by turning off the built-in mouse and using a regular mouse.
My problem was solved. It was an issue with the anti virus software called Zone Alarm. I had to turn off a feature that tracked my key strokes and then the problem went away.