Can't ping PCs while connected to a Router [Solved/Closed]

laldu - Oct 10, 2008 at 04:19 PM - Latest reply:  tammo
- Feb 28, 2018 at 03:43 AM
Hello, I connected to computers to my Linksys router. I can not ping each other. Request timed out. Therefore, I can not share files and printer. when I do ipconfig I see their ip addresses but can not ping.
Routers ip: 192.168.1.1
PC 1 : 192.168.1.100
PC 2: 192.168.1.101

I cheked firewall and all other connections but still not successful. Someone please help. Many thanks!
See more 

34 replies

Best answer
45
Thank you
check the icmp settings of windows

Start>>Run>>firewall.cpl>>Advanced>>Click "Settings" under ICMP

the only option that should be checked is "Allow incoming echo request", hope this helps

Thank you, griever09 45

Something to say? Add comment

CCM has helped 1875 users this month

Jiminnybillybob - Jul 13, 2010 at 09:46 AM
Thanks mate
solved my problem
thanks for the help - May 29, 2013 at 07:59 PM
thanks for the help
Thank you it is working well
thanks alot ...it worked for me
13
Thank you
I have the same problem, but
I can ping routeer, router can not ping PCs, PCs can not ping each other....
Both PCs have internet connection through router.

The firewalls are off

ICMP settings were changed as described in the second post, but it does not help either
13
Thank you
All,


I solved a very similar problem on my network last night:
Linksys WRT54G Router V1.0
3 XP Pro Machines
1 Win 7 machine

All were working, pinging and sharing fine until I replaced the router with a WRT54G V8.0. After that, I could only ping some machines from some others, and could not share any drives or printers.

I was positive this had to be a router problem, but it turns out it was a weird McAfee firewall issue (probably something to do with how McAfee relates to the routers MAC address).

The solution that worked for me was as follows:
The range of trusted networks in the McAfee Firewall settings was correct (192.168.1.1 -> 192.168.1.255). However, after trying everything else I could think of, I deleted the rule that allowed this trusted range within the McAfee Firewall settings. I then recreated it exactly as it was, and Voila! I could now ping that computer from every other computer. I did the same on all machines and the problem was solved.

I hope this helps someone.
Thanks; this worked for me too. There were conflicting entries for the IP range I use, some Trusted and some Public.
I suspect a bug in the McAfee update as it had happened to several PCs. One of them was totally messed up, with hundreds of bizarre ranges. It's going to take an age to remove them all.
5
Thank you
I have fixed my problem with ping by configuring McAfee firewall. It seems like even in disabled state it stops ping requests(may be i'm wrong, but it's gone...)
Thanks a lot man! Same exact issue, with McAfee closed it was still blocking. I added the new ip as trusted and it worked.

Thanks again!
4
Thank you
I had the same problem, with my US Robotics router 4 years ago and forgot how I resolved the problem. Had the same problem with my new Linksys router.

It is not the router, it is your computer firewall. I use Norton and you need to configure the firewall networking trusted addresses. Enter the non routeable IP range that your wireless network is using e.g. 192.168.1.100 to say 192.168.1.110. I do not use Windows Firewall, but I presume it has similar settings.

I am now able to share files and printer again. Next time I buy a router I will have probably forgotten all this and will have to go through the same learning curve again.

Richard
sajan 4 Posts Tuesday January 27, 2009Registration date June 24, 2009 Last seen - Feb 2, 2009 at 12:11 AM
4
Thank you
Hi dear,
If ur using MS server OS then
Please check in Adminstrative tools->Routing and Remote Access->Right click on Computer Name ->Click on "Configure and Enable Routing and Remote Access"

And then try to ping to ur both the PC's. :-)

If still not then try to reboot if the above procedure is done. :-)
LancSS 3 Posts Thursday August 13, 2009Registration date September 27, 2009 Last seen - Sep 27, 2009 at 01:19 PM
4
Thank you
I have exactly the same problem. 6 PCs (3 Desktops all XP, 2 Laptops with Vista and a PS3). All connected through Linksys wireless router. Two Laptops can be pinged between the 2 but rest do not. All I want is the PC connected to Printer could be shared. Have tried one by one almost everything suggested but still no luck.
I disabled the firewall in my McAfee 'Total Protection Service'. Then this PC could ping and be pinged.
I'm running a cybercafe with windows xp computers, hp printer and tinasoft. A week ago my network configuration was fine all computers are identified by the server, I can print from the network and the tinasoft running smothly.
But now. But now, my tinasoft is still running with all computers identified but I cannot share, print, ping or even see network computers from the server. all IP's, workgroup and other are currect.
i have tried to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services but still no avail, my firewall is turned off. I just don't know what to do. please
4
Thank you
Pls, Check wheather the ICMP is enable on your firewall ( if you have) or check on your machine is ticked for the following "Allow echo requests"


Try it its useful
3
Thank you
Check to see if the option AP isolation is checked in the advanced Wireless settings of your Linksys router. Are all the computers wireless ? Is so this could be the issue.
Sims: Wireless | Advanced Wireless Settings | AP Isolation was off on my router at home where it is working and on this router where it is not working. However, under Security | Firewall, Block Anonymous Internet Requests was not checked at home but checked on this other router. I unchecked it and now some of the PCs list the others in the Network list. The one with the printer, however, does not have the others listed and the others still can't access that shared printer. So, I have more work to do, though we did make some progress.

Thanks,
Rob
QuantaCat > QuantaCat - Mar 13, 2009 at 07:26 AM
Update: Apparently this change did it - unblocked anonymous Internet request on my router. Apparently it took a little time, perhaps system reboots, whatever, for it to take effect. All the PCs can print to the shared printer now - all see all PCs, etc., etc.

Thanks to all for your suggestions!
Rob
GoSpartans > QuantaCat - Mar 24, 2009 at 11:11 AM
Are you happy with your AT&T DSL service and are you on Pro DSL (3.0) or higher? I'm thinking about changing to AT&T.

Thanks.
oh my god that was it - thank you thank you thank you
i have been trying everything in every forum and every faq everywhere for weeks,
and that setting (which says nowhere what it is) was the whole problem pffffh :p
3
Thank you
Hello,
I'm running a cybercafe with windows xp computers, hp printer and tinasoft. A week ago my network configuration was fine all computers are identified by the server, I can print from the network and the tinasoft running smothly.
But now. But now, my tinasoft is still running with all computers identified but I cannot share, print, ping or even see network computers from the server. all IP's, workgroup and other are currect.
i have tried to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services but still no avail, my firewall is turned off. I just don't know what to do. please
2
Thank you
Similar issue, different problem.

I just hooked up a Linksys wireless router to a two printer, two XP LAN network. Previously, a Linksys wired router was the hub and worked perfectly fine. This is the second wireless router brand I've tried with the exact same results.

The network shares the printers and some shared software/files from the host computer. This is not a home network, only mapped drives to software and shared printers. All are wired (plan on hooking in with a wireless laptop once this issue is fixed). Both computers can ping the printers and router. Computer A (host) can ping comp. B (client). However, computer B cannot ping A.

Windows firewalls are off on both computers. The IP address are fine and so are the subnet mask ids.

Literally, if I unplug the wireless router and reinstall the wired router, the problem is solved.

Any thoughts. I figure it has to be a firewall on A but can't figure out where. ICMP boxes are checked for incoming echo requests on both.

HELP!
I do have a problem related to ping the PCs.
I do have two PCs installed in my office.
I can ping the second computer from first computer but cant ping first from second computer.

Please help
2
Thank you
In order for your computes to ping each other on a network level, they have to be on the same network. Go to start menu, right-click Computer(Vista) or My Computer(XP) and select Properties. In Vista, change the workgroup name so they're the same on both computers. In XP, in the properties windows go to Computer Name tab and change workgroup name on both computers. Both computers are no on the same network, but the computer must be restarted for changes to take effect. Also, if you want to enable printer and file sharing, for XP open windows explorer (start menu>all programs>accessories>windows explorer). In the left window find the C drive and right-click and choose "sharing and security..." and in the properties window under Sharing tab, click the bottom sentence. In the "Network sharing and security" window, check the "Share this folder on the network" box and then name the folder what you want. If you want, you can allow others on the network to change files by click the "Allow network users to change my files" box...otherwise, leave it unchecked. Click OK and you now have a network sharing folder. Go through the same process on the other computer (if running XP) to enable printer and file sharing on there too. On Vista..well, you'll have to look it up cause I can't remember at the moment. I use Win7 and the features are slightly different I believe.
Thanks, Dark Nuker. On my PC, all those things are done already, except enabling printer sharing on the other computers even though they don't have printers attached. Maybe, by some screwy logic, it's now required by Vista - I'll try that.

Rob
QPR_FC > QuantaCat - Mar 12, 2009 at 09:24 PM
Hi,

I had exactly the same issue. I pulled all my hair out as it used to work before I moved house.

Same workgroup
tried dynamic DHCP IP, then static IP
disabled IPv6
Switched off firewalls
Rebooted modem/router
Updated firmware modem/router....factory reset, entered all settings again
Tried MAC filtering
Reboot PCs
these are just some of the things I tried!

Then one day, I remembered changing the security from WPA to WPA2 just before the house move, although everything 'appeared' normal I must have lost the connections between PCs at that time and not discovered it.
I changed the security back to WPA and hey presto, all PCs could talk to each other again.

Hope it works.....I know its frustrating.
2
Thank you
Thankyou,

Now I m able to ping my window m/c from unix. It was very help full griever09
2
Thank you
I have Norton antivirus and had the same problem. If you have Norton, turn off its firewall.
quantacat 1 Posts Thursday February 12, 2009Registration date February 13, 2009 Last seen - Feb 13, 2009 at 02:28 PM
1
Thank you
Hi: I have a similar problem, but none of these solutions has helped. I have installed 6 new Vista PCs on a Linksys router wirelessly. All can access the Internet. All can ping the router. The router can ping all PCs. One PC can ping some of the addresses. All have Network Discovery enabled. One has a printer it's sharing without a password. LLTD is enabled on all wireless (PCI) network adapaters. I uninstalled Norton Protection Center that came with, and replaced it with just Norton Antivirus. All Vista firewalls are disabled and there is no other firewall software that I know of. All are part of the same workgroup and on the same network. When I look at the Network Map for all PCs, they have only the one host, the network and the Internet - nothing else. What gives?

At home, I have 3 XP PCs and a Vista PC all talking together, sharing, etc. nicely without a single hiccup. What gives with these jokers?

Thanks,
Rob
Put in your computers IP address in the "Trusted" list inyour Firewall Software. In McAfee the trusted "range" 192.168.1.1 though 192.168.1.255 was there but it wasn't working. I added my laptops specific address 192.168.1.3 and 192.168.1.4, then they were able to ping eachother and the router could ping the laptops.
Quantacat > wcruz - Feb 17, 2009 at 08:31 AM
Wcruz: Thanks, but the only firewall on the system is Vista's, and it's inactive. Before I removed Norton Protection Center, I tried entering the MAC addresses of each machine to no avail. So it seems it's something other than a firewall issue.

I have a Linksys wireless router at home that has 3 XP and one Vista system all talking nicely together even though the Vista is part of a different workgroup.

Thanks for replying, anyhow.