Get IP From Router But Won't Connect To Out [Solved/Closed]

- Oct 21, 2008 at 08:51 PM - Latest reply:  LostUser
- Nov 7, 2014 at 02:12 PM
Hello,
I'm having a new problem on an xp machine that has worked for the last two years. I have a pc that is wired to a router and is receiving an ip address correctly but will not connect to the internet via any of my applications (tried IE, Outlook and Quicken). Other machines using the same router are working. I have tried ipconfig /release and /renew and obtain the same ip address but will still not work. I've disabled firewall to test to see if a setting changed. Any suggestons are appreciated.
See more 

22 replies

Best answer
Posts
19469
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
November 17, 2018
- Oct 21, 2008 at 10:39 PM
37
Thank you
You might try this:

You may have a DHCP problem - DHCP gets the IP address from the router -

the first thing to check is NetBIOS over TCP/IP

>> Open up network connections (In Control Panel)
>> Right click on your network (Your wireless connection)
>> Click Properties
>> In the "General" tab click "Internet protocol" (TCP/IP)
>> Click "Properies"
>> Click "Advanced"
>> Click the "WINS" tab
>> Click the Enable NetBIOS Over TCP/IP button (This is NOT the default option)

The next item to check is the DHCP service itself:

click on start, run, enter 'services.msc'

look for DHCP client....
if it says acquiring network address that means that the dhcp client is DISABLED OR STOPTED... highlight the DHCP client and on the left side you will see "START" the service, click on it and then it will say "STOP, RESTART" then double click on the service and on the startup type select automatic, apply

Symptom
DHCP Client Service may not start automatically. When you attempt to start the Service manually, the following error may be displayed:

Error: Could not start the DHCP Client Service on local computer
Error 1068: The dependency service or group failed to start.

Resolution
The DHCP Client Service in Windows XP, depends on these three components:
* AFD
* NetBios over Tcpip
* TCP/IP Protocol Driver

If one of the above drivers fail to start, then the DHCP Client Service may not start.
Step I - Make sure that the three driver files are present

Open Windows Explorer and navigate to /Windir/System32Drivers folder. Make sure that the following files are present in the folder:

* afd.sys
* tcpip.sys
* netbt.sys

If one or more of the above driver files are missing, extract them from the Windows XP CD-ROM or from the ServicePackFilesi386 folder, whichever is the latest version.

Step II - Verify the number of Dependencies

From other sources in the Web, I've found that some versions of Norton Antivirus (NAV) adds an entry to the DHCP Service Dependencies, and removing NAV does not remove the appropriate value from the DHCP Dependencies.

To quickly determine the Dependency services for DHCP Client Service, type the following command in Start, Run dialog:

CMD /K SC QC DHCP

Verify the output. It should be exactly as below:

[SC] GetServiceConfig SUCCESS

SERVICE_NAME: dhcp
TYPE : 20 WIN32_SHARE_PROCESS
START_TYPE : 2 AUTO_START
ERROR_CONTROL : 1 NORMAL
BINARY_PATH_NAME : C:WINDOWSsystem32svchost.exe -k netsvcs
LOAD_ORDER_GROUP : TDI
TAG : 0
DISPLAY_NAME : DHCP Client
DEPENDENCIES : Tcpip
: Afd
: NetBT
SERVICE_START_NAME : LocalSystem

If additional entries are listed under DEPENDENCIES...
If any other additional drivers or Services are mentioned in the DEPENDENCIES section, you need to remove them via the registry. Follow these steps:

* Click Start, Run and type Regedit.exe
* Navigate to the following branch:
* Backup the branch to a REG file

HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Services Dhcp

* Double-click DependOnService MULTI_SZ value and set it's data as follows:

Tcpip
Afd
NetBT

* Close Regedit.exe

Step III - Verify that the Dependency Service / components are running

Next step is to verify that the three dependency components are running. As the three components are actually the Kernel Drivers (Driver Service), you need to manage then via the Device Manager. Follow these steps:

* Click Start, Run and type DEVMGMT.MSC
* In the View menu, click Show hidden devices
* Double-click Non-Plug and Play drivers section
* Double-click the entry - AFD Networking Support Environment, and click the Driver tab
* Set the Startup type to System.
* Start the service. Note down the error message if any.
* Similarly start the two other drivers namely:

* TCP/IP Protocol Driver
* NetBios over Tcpip

* Close Device Manager and restart Windows.

report back on your status/results -

Thank you, xpcman 37

Something to say? Add comment

CCM has helped 1672 users this month

hey man thanks for this solution worked great... couldnt figure out why this stopped workin all of a sudden... had been scratchin head for the last day and a half....
xpcman, I tried what you suggested for someone back on October 2008. The only thing I was not able to do was the Afd in Device Managment, it wasn't there. I still get the messsge "Can not display Web Page". I just recently purchased a Compaq (HP) laptop computer that has Windows Vista and Internet Explorer 7. I've installed a D-Link DIR-600 wireless router. Will appreciate any other suggestions.
ok man your instructions works fine.
i did everything on activations you wrote on that site, now I need to know how to open udp ports over that conection dhcp? cause ie do not get good p2p conection since udp ports are close or something like that the program says, ill be waiting your post thanks anyway.

Ricky
I sill not working for me xpcman ... what should I do? Everything is working, the AFD, netbt and tcpip is running ok, I can ping all computers on the network, I can even access to 192.168.1.1 router page, but no signal of internet at any application ...

Windows IP Configuration

Host Name . . . . . . . . . . . . : GLASS
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for
VMnet1
Physical Address. . . . . . . . . : 00-50-56-C0-00-01
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.25.142
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Marvell Yukon 88E8036 PCI-E Fast Eth
ernet Controller
Physical Address. . . . . . . . . : 00-13-A9-4B-35-42

Ethernet adapter Wireless Network Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : LAN-Express BCM 802.11g PCI-E Adapte
r
Physical Address. . . . . . . . . : 00-16-CF-34-9D-E9
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.6
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
Lease Obtained. . . . . . . . . . : 23 April 2010 18:36:16
Lease Expires . . . . . . . . . . : 24 April 2010 18:36:16

C:\Documents and Settings\Rubylov>
Hi xpman

I have the same problem.
I did all the steps you advice and still no internet on the pc.
Please advise what should I do
14
Thank you
I was having the same problem, everything worked but IE. My solution was under the IE menu... goto Tools... Internet Options... Connections... Lan settings.... and under 'Proxy Server' my IE default had use proxy server as checked... Unchecked this box... all worked fine. Hope this helps.
Oh Jeez Thanks so much. I spent all day yesterday trying to fix the same problem and that was the solution!!! Thanks.
Thanks for the perfect simple answer to frustrating problem!!!
I'd like to add my thanks for this amazingly simple and correct solution to so many connectivity issues. A lot of stuff such as quicken and windows update apparently depends on IE having it's connection settings correct. If you don't use IE as your browser, you may not be aware that there is an incorrect connection setting in there. At least that's what happened to me. It was driving me crazy for several days until I came across this suggestion and it fixed it.
Wow - spent an hour trying to figure it out and your solution worked in two minutes. Thanks so much!!
worked like a charm!! spent 2hrs messing with everything else I could think of thank you for the 4 sec fix
- Feb 19, 2009 at 11:28 AM
9
Thank you
Hi Im running DHCP on the server.

All clients are getting the IP address from the server, but cant connect to the internet.

Operating system on server: Windows Server 2003 Std edt
Operating System on Client: Windows Vista SP1

When I restart DHCP client on the service on the server Internet works for 5-10min than the internet stop working. same happen on the server and same on the client.

Can someone help me out?

Thanks

Paul
Check your DNS settings
6
Thank you
Thanks so much for the detailed suggestions. I was able to get my internet back by executing your recommended steps and running WinsockXPFix. I appreciate your very detailed help.
5
Thank you
windows ip adress is messed up from a virus.... can I repair this?
4
Thank you
The funny thing is that I can connect to skype and talk ... ? But no IE or FF.. nor Win Updates..

Any ideas?

Thanks
Posts
1
Registration date
Sunday June 20, 2010
Last seen
June 20, 2010
- Jun 20, 2010 at 12:13 AM
2
Thank you
ceters name
2
Thank you
The DHCP solution works if you are not getting a valid IP address.
If you are not getting and IP address or you get an IP address starting with 169 then you are not getting a valid DHCP address. Example: 169.204.122.64

If you are getting an IP address similar to other devices on your network, then you likely have a different issue.

I had a very similar issue as the OP. My internal network connection was fine and Network and Sharing Center showed a network and internet connection with no Red X or Yellow Triagnles. However, I could not get out to the internet or ping internet sites like google.com (or its equivalent IP address). Mind you, that not all websites are pingable.
I had checked Proxy settings in IE, disabled IPv6, checked netbios Default (use Netbio setting from DHCP server...), uninstalled and reinstalled Client for Microsoft Windows Networks, and a few other things. DNS was fine as well.

What fixed my issue was resetting the Winsock TCPIP configuration.
I used the following command after opening up a command prompt as administrator.

netsh winsock reset

I was immediately able to ping google.com, go to various websites, etc. but a reboot should be done right after.

Hope this helps someone.
1
Thank you
Hello,


I have a similar problem. So I tried what you wrote, and at the end I coulnd not find the AFD in Device Manager...


Thanks